Skip to content

@atomjump atomjump released this Feb 8, 2021

Requirements: Apache 2, PHP (tested with 5.3/5.5/7.0/7.1, with php-curl, php-mbstring, php-zip, php-xml support included), MySQL 5+, Linux server. Or a linux virtual machine on Windows.

International sentiment analysis now in 15 of the world's most popular languages, to help detect instances of hate speech.

If you are upgrading from an existing version prior to v2.8.9, and have sentiment analysis enabled, you should
'cd yourserver/node; npm install'
because the libraries need to be updated (some installations may need 'sudo npm install')

This version includes some additional documentation, and a nicer email confirmation screen.

Assets 2

@atomjump atomjump released this Jan 27, 2021 · 6 commits to master since this release

Requirements: Apache 2, PHP (tested with 5.3/5.5/7.0/7.1, with php-curl, php-mbstring, php-zip, php-xml support included), MySQL 5+, Linux server. Or a linux virtual machine on Windows.

International sentiment analysis now in 15 of the world's most popular languages, to help detect instances of hate speech.

If you are upgrading from an existing version prior to v2.8.9, and have sentiment analysis enabled, you should
'cd yourserver/node; npm install'
because the libraries need to be updated (some installations may need 'sudo npm install')

Updated to AtomJump-specific source links.

Assets 2

@atomjump atomjump released this Jan 18, 2021 · 7 commits to master since this release

Requirements: Apache 2, PHP (tested with 5.3/5.5/7.0/7.1, with php-curl, php-mbstring, php-zip, php-xml support included), MySQL 5+, Linux server. Or a linux virtual machine on Windows.

International sentiment analysis now in 15 of the world's most popular languages, to help detect instances of hate speech.

If you are upgrading from an existing version prior to v2.8.9, and have sentiment analysis enabled, you should
'cd yourserver/node; npm install'
because the libraries need to be updated (some installations may need 'sudo npm install')

Assets 2

@atomjump atomjump released this Jan 17, 2021 · 43 commits to master since this release

Requirements: Apache 2, PHP (tested with 5.3/5.5/7.0/7.1, with php-curl, php-mbstring, php-zip, php-xml support included), MySQL 5+, Linux server. Or a linux virtual machine on Windows.

Allow checks on sentiment from 'scaleUp' messaging databases as well as the main database.

Assets 2

@atomjump atomjump released this Jan 13, 2021 · 57 commits to master since this release

Requirements: Apache 2, PHP (tested with 5.3/5.5/7.0/7.1, with php-curl, php-mbstring, php-zip, php-xml support included), MySQL 5+, Linux server. Or a linux virtual machine on Windows.

Typographical error on the categories of the 'warning disk usage' and 'warning CPU usage'. No code changes.

Assets 2

@atomjump atomjump released this Jan 13, 2021 · 58 commits to master since this release

Requirements: Apache 2, PHP (tested with 5.3/5.5/7.0/7.1, with php-curl, php-mbstring, php-zip, php-xml support included), MySQL 5+, Linux server. Or a linux virtual machine on Windows.

Typographical error on the names of the warning files in ver 2.8.6. No code changes.

Assets 2

@atomjump atomjump released this Jan 13, 2021 · 59 commits to master since this release

Requirements: Apache 2, PHP (tested with 5.3/5.5/7.0/7.1, with php-curl, php-mbstring, php-zip, php-xml support included), MySQL 5+, Linux server. Or a linux virtual machine on Windows.

Fixed the pre-warning (server-side) notification mechanism if the server is going to reach it's capacity soon. The off-state should now work correctly.

Assets 2

@atomjump atomjump released this Jan 12, 2021 · 60 commits to master since this release

Requirements: Apache 2, PHP (tested with 5.3/5.5/7.0/7.1, with php-curl, php-mbstring, php-zip, php-xml support included), MySQL 5+, Linux server. Or a linux virtual machine on Windows.

Provide a pre-warning (server-side) notification mechanism if the server is going to reach it's capacity soon. This includes the hardware server's CPU and disk space.

Note: the file 'within-capacity-db-warning.html' has changed to 'within-db-capacity-warning.html' from v2.8.4, which was a typographical error.

Assets 2

@atomjump atomjump released this Jan 12, 2021 · 61 commits to master since this release

Requirements: Apache 2, PHP (tested with 5.3/5.5/7.0/7.1, with php-curl, php-mbstring, php-zip, php-xml support included), MySQL 5+, Linux server. Or a linux virtual machine on Windows.

Provide a pre-warning (server-side) notification mechanism if the server is going to reach it's capacity soon. This includes the hardware server's CPU and disk space.

Note: the file 'within-capacity-warning.html' has changed to 'within-capacity-db-warning.html' from v2.8.3, to allow for a variety of different warning types, including the new 'within-capacity-disk-warning.html' and 'within-capacity-cpu-warning.html'

Assets 2

@atomjump atomjump released this Jan 11, 2021 · 72 commits to master since this release

Requirements: Apache 2, PHP (tested with 5.3/5.5/7.0/7.1, with php-curl, php-mbstring, php-zip, php-xml support included), MySQL 5+, Linux server. Or a linux virtual machine on Windows.

Provide a pre-warning (server-side) notification mechanism if the server is going reach it's capacity soon. This is set before users start to see the 'concurrent users warning', when that limit is reached.

The target folder for this capacity checker has changed from v2.8.2, so that the file will be auto-created given the typical current permissions in the images/im/ folder.

Assets 2