Skeleton of my root directory.
Shell Vim script Go
Switch branches/tags
Nothing to show
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
.config/wingo
.vim
embedded
.Xmodmap
.gitignore
.gitmodules
.gmrunrc
.vimrc
.xinitrc
.zshrc
README.md
redock

README.md

.files

  1. check out the repo
  2. update submodules2
  3. symlink dot files
  4. install system dependencies4

2updating submodules

git submodule init
git submodule update --recursive

4installing dependencies

sudo emerge --ask --tree \
	dev-python/flake8 \
	dev-python/jedi \
	dev-ruby/sass \
	net-libs/nodejs

Flake8 will pull in PEP8 and PyFlakes. Node.js is required by less.js.