Permalink
Browse files

Improve gemspec and Rakefile based on defaults created by

  • Loading branch information...
1 parent 0753b53 commit e1383f22d0c0a7e6f8d3bc152af67991a2c64f81 @bowsersenior bowsersenior committed Aug 4, 2011
Showing with 18 additions and 27 deletions.
  1. +4 −2 .gitignore
  2. +1 −5 Rakefile
  3. +13 −20 yacht.gemspec
View
@@ -1,7 +1,9 @@
+*.gem
+.bundle
+Gemfile.lock
+pkg/*
coverage
tmp
doc
.yardoc
-*.gem
.DS_Store
-Gemfile.lock
View
@@ -1,8 +1,4 @@
-# encoding: utf-8
-require 'rubygems'
-require 'bundler'
-Bundler.setup
-Bundler::GemHelper.install_tasks
+require 'bundler/gem_tasks'
Dir['gem_tasks/**/*.rake'].each { |rake| load rake }
View
@@ -1,35 +1,28 @@
# -*- encoding: utf-8 -*-
-lib = File.expand_path('../lib/', __FILE__)
-$:.unshift lib unless $:.include?(lib)
+$:.push File.expand_path("../lib", __FILE__)
require 'yacht/version'
Gem::Specification.new do |s|
s.name = "yacht"
s.version = Yacht::VERSION
s.authors = ["Mani Tadayon", "Rico Rodriquez Collins"]
- s.description = "Yacht is Yet Another Configuration Helper Tool."
- s.summary = "yacht-#{s.version}"
s.email = ["mtadayon@atti.com", "rcollins@atti.com"]
s.homepage = "https://github.com/attinteractive/yacht"
+ s.summary = "yacht-#{s.version}"
+ s.description = "Yacht is Yet Another Configuration Helper Tool."
- s.platform = Gem::Platform::RUBY
-
- s.add_dependency "classy_struct", ">= 0.3.2"
+ s.add_dependency "classy_struct", "~> 0.3.2"
s.add_dependency "json"
- s.add_development_dependency "gherkin", '>= 2.4.0'
+ s.add_development_dependency "gherkin", '~> 2.4.0'
s.add_development_dependency "cucumber", '~> 1.0'
s.add_development_dependency 'aruba'
- s.add_development_dependency "rspec", '>= 2.6.0'
- s.add_development_dependency "simplecov", '>= 0.4.1'
-
-
-
- s.required_rubygems_version = ">= 1.3.7"
- s.files = `git ls-files`.split("\n")
- s.test_files = `git ls-files -- spec/*`.split("\n")
- s.extra_rdoc_files = ["LICENSE", "README.rdoc"]
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_path = "lib"
-end
+ s.add_development_dependency "rspec", '~> 2.6.0'
+ s.add_development_dependency "simplecov", '~> 0.4.1'
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
+end

0 comments on commit e1383f2

Please sign in to comment.