Related Posts for WordPress - Polylang Compatibility
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
LICENSE
composer.json
index.php
readme.md
rp4wp-polylang-compatibility.php

readme.md

Related Posts for WordPress - Polylang Compatibility

Contributors: Teemu Suoranta

Tags: Related Posts for WordPress, Related Posts, Polylang, WordPress

License: GPLv2 or later

Description

This is an add-on to Related Posts for WordPress that adds compatibility to Polylang.

Requirements for the plugin:

  • Related Posts for WordPress (Premium)
  • Polylang

I am not a developer for Related Posts for WordPress. This plugin is based on their WPML compatibility plugin.

Installation

How-to use:

  • Install and activate this add-on
  • Done

Composer:

$ composer aucor/rp4wp-polylang-compatibility

With composer.json:

{
  "require": {
    "aucor/rp4wp-polylang-compatibility": "*"
  },
  "extra": {
    "installer-paths": {
      "htdocs/wp-content/plugins/{$name}/": ["type:wordpress-plugin"]
    }
  }
}

Issues and feature whishlist

Issues:

There's still posts that are linked to wrong languages:

  • Go to Related Posts -> Installer -> Re-install this post type (and re-link everything)

No support for multilingual stop words

  • Make a PR!