Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Concurrent Animations not working #46

Open
aqm5181 opened this issue Apr 28, 2016 · 5 comments

Comments

@aqm5181
Copy link

commented Apr 28, 2016

Hi,

ive uploaded a simple example to plunkr:
http://plnkr.co/edit/zGKBeN?p=preview

Basically, when there are multiple divs next to each other with animations applied via au-animate, only the top div is animated. This applied to the latest framework version: "1.0.0-beta.1.2.2".

Could you please have a look.

thanks

Aboobaker Mahomed

@EisenbergEffect

This comment has been minimized.

Copy link
Member

commented Apr 28, 2016

@zewa666 Can you look into this?

@zewa666 zewa666 self-assigned this Apr 29, 2016

@EisenbergEffect

This comment has been minimized.

Copy link
Member

commented Jul 6, 2016

@zewa666 Ping.

@EisenbergEffect EisenbergEffect added the bug label Jul 6, 2016

@thrillstone

This comment has been minimized.

Copy link

commented Nov 24, 2016

@zewa666, is there any update on this bug? From what I can tell, the bug isn't with the CSS animator but instead with the ViewSlot's implementation of animateView which only ever passes a single element from a view to the animator when it calls the getAnimatableElement(view) function. I would imagine that it should be getting all of the au-animate elements and looping over them, getting the promises from the this.animator.enter() calls and joining the promises to be returned. I'm not so sure about that last part though, haven't dug into the code beyond this point yet.

@zewa666

This comment has been minimized.

Copy link
Member

commented Nov 24, 2016

I did not yet have the chance to look at it, sry :(
Will try to catch up asap

@browillow

This comment has been minimized.

Copy link

commented Nov 30, 2017

I have confirmed that this is still an existing issue with aurelia-animator-css@1.0.4
My use case was having individual au-animate classes on a parent div and a child div. The parent div animates successfully, but the child div does not. I confirmed the OP sibling case still doesn't work as well.

It would be a really nice improvement if multiple au-animate elements were supported in the same view.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.