Permalink
Browse files

fix(generator): fix babel syntax error when running "au generate"

closes #954
  • Loading branch information...
huochunpeng committed Nov 14, 2018
1 parent 9d4bbbe commit 8eb19e7578b5d537553f7c90a2c8f1ac1a25c243
Showing with 76 additions and 5 deletions.
  1. +2 −0 lib/project.js
  2. +68 −1 package-lock.json
  3. +6 −4 package.json
@@ -209,6 +209,8 @@ function installBabel() {
require('@babel/register')({
babelrc: false,
plugins: [
['@babel/plugin-proposal-decorators', { legacy: true }],
['@babel/plugin-proposal-class-properties', { loose: true }],
'@babel/plugin-transform-modules-commonjs'
],
only: [/aurelia_project/]

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.
@@ -33,14 +33,16 @@
"url": "https://github.com/aurelia/cli"
},
"dependencies": {
"aurelia-dependency-injection": "^1.4.1",
"aurelia-logging": "^1.5.0",
"aurelia-polyfills": "^1.3.0",
"@babel/core": "^7.1.2",
"@babel/plugin-proposal-class-properties": "^7.1.0",
"@babel/plugin-proposal-decorators": "^7.1.6",
"@babel/plugin-transform-modules-amd": "^7.1.0",
"@babel/plugin-transform-modules-commonjs": "^7.1.0",
"@babel/core": "^7.1.2",
"@babel/polyfill": "^7.0.0",
"@babel/register": "^7.0.0",
"aurelia-dependency-injection": "^1.4.1",
"aurelia-logging": "^1.5.0",
"aurelia-polyfills": "^1.3.0",
"del": "^3.0.0",
"esprima": "^4.0.1",
"glob": "^7.1.3",

0 comments on commit 8eb19e7

Please sign in to comment.