Permalink
Browse files

fix(cli): default bundler is webpack, so move to position 1

Because index 0 is used as a means of classifying an option as being (Default) when you choose custom in the CLI at present, RequireJS is presented in the UI as the default. However, Webpack is now the default. The fix for this is to move Webpack to the top of the list so the code on line 155 `text += ' (Default)';` applies to Webpack.
  • Loading branch information...
Vheissu committed Apr 10, 2018
1 parent 145895a commit d0ff2ee2f975b1eb9036fb40e5d4f460712aff60
Showing with 5 additions and 5 deletions.
  1. +5 −5 lib/commands/new/new-application.json
@@ -132,6 +132,11 @@
"question": "Which module loader / bundler would you like to use?",
"stateProperty": "loaderBundler",
"options": [
{
"displayName": "Webpack",
"description": "A powerful bundler",
"value": "webpack"
},
{
"displayName": "RequireJS",
"description": "A file and module loader for JavaScript.",
@@ -141,11 +146,6 @@
"displayName": "SystemJS",
"description": "Dynamic ES module loader",
"value": "systemjs"
},
{
"displayName": "Webpack",
"description": "A powerful bundler",
"value": "webpack"
}
]
},

0 comments on commit d0ff2ee

Please sign in to comment.