New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Ensure .viewModel or .view #312

Closed
StrahilKazlachev opened this Issue Jun 27, 2017 · 0 comments

Comments

Projects
None yet
1 participant
@StrahilKazlachev
Contributor

StrahilKazlachev commented Jun 27, 2017

I'm submitting a bug report

  • Library Version:
    1.0.0-rc.1.0.3

Please tell us about your environment:

  • Browser:
    all

  • Language:
    all

Current behavior:
When CompositionEngine.prototype.compose is called with context that has both .viewModel and .view missing the dialog service does not fail, but it continues and calls .showDialog on the renderer.

Expected/desired behavior:

  • What is the expected behavior?
    Before composing the dialog the composition context has to be validated that it has at least .viewModel or .view set. If both are missing we should reject with an error, with a descriptive message.

  • What is the motivation / use case for changing the behavior?
    This error case should be easy to debug/detect - #298.

@StrahilKazlachev StrahilKazlachev self-assigned this Jun 27, 2017

StrahilKazlachev added a commit to StrahilKazlachev/dialog that referenced this issue Jul 1, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment