Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

gemcutter. jewler.

  • Loading branch information...
commit 9849c881a99fa14e2f08de1dfe04355cee805a85 1 parent d4d49e9
@aurelian authored
View
21 .gitignore
@@ -1,2 +1,21 @@
-__git__
+## MAC OS
+.DS_Store
+
+## TEXTMATE
+*.tmproj
+tmtags
+
+## EMACS
+*~
+\#*
+.\#*
+
+## VIM
*.swp
+
+## PROJECT::GENERAL
+coverage
+rdoc
+pkg
+
+## PROJECT::SPECIFIC
View
55 Rakefile
@@ -0,0 +1,55 @@
+require 'rubygems'
+require 'rake'
+
+begin
+ require 'jeweler'
+ Jeweler::Tasks.new do |gem|
+ gem.name = "grapi"
+ gem.summary = %Q{Ruby client for unofficial Google Reader API}
+ gem.description = %Q{Ruby client for unofficial Google Reader API}
+ gem.email = "oancea@gmail.com"
+ gem.homepage = "http://github.com/aurelian/grapi"
+ gem.authors = ["Aurelian Oancea"]
+ gem.add_dependency("curb", ">=0.6.1.0")
+ gem.add_dependency("nokogiri", ">=1.4.1")
+ gem.add_dependency("loofah", ">=0.4.1")
+ # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
+ end
+ Jeweler::GemcutterTasks.new
+rescue LoadError
+ puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"
+end
+
+require 'rake/testtask'
+Rake::TestTask.new(:test) do |test|
+ test.libs << 'lib' << 'test'
+ test.pattern = 'test/**/test_*.rb'
+ test.verbose = true
+end
+
+begin
+ require 'rcov/rcovtask'
+ Rcov::RcovTask.new do |test|
+ test.libs << 'test'
+ test.pattern = 'test/**/test_*.rb'
+ test.verbose = true
+ end
+rescue LoadError
+ task :rcov do
+ abort "RCov is not available. In order to run rcov, you must: sudo gem install spicycode-rcov"
+ end
+end
+
+task :test => :check_dependencies
+
+task :default => :test
+
+require 'rake/rdoctask'
+Rake::RDocTask.new do |rdoc|
+ version = File.exist?('VERSION') ? File.read('VERSION') : ""
+
+ rdoc.rdoc_dir = 'rdoc'
+ rdoc.title = "grapi #{version}"
+ rdoc.rdoc_files.include('README*')
+ rdoc.rdoc_files.include('lib/**/*.rb')
+end
View
2  VERSION
@@ -1 +1 @@
-0.0.0
+0.2.0
View
62 grapi.gemspec
@@ -0,0 +1,62 @@
+# Generated by jeweler
+# DO NOT EDIT THIS FILE DIRECTLY
+# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = %q{grapi}
+ s.version = "0.2.0"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Aurelian Oancea"]
+ s.date = %q{2009-12-29}
+ s.description = %q{Ruby client for unofficial Google Reader API}
+ s.email = %q{oancea@gmail.com}
+ s.extra_rdoc_files = [
+ "README.textile"
+ ]
+ s.files = [
+ ".gitignore",
+ "MIT-LICENSE",
+ "README.textile",
+ "Rakefile",
+ "VERSION",
+ "example.rb",
+ "grapi.gemspec",
+ "lib/core_ext/string.rb",
+ "lib/grapi.rb",
+ "lib/grapi/parser.rb",
+ "lib/grapi/reader.rb",
+ "test/helper.rb",
+ "test/test_grapi.rb"
+ ]
+ s.homepage = %q{http://github.com/aurelian/grapi}
+ s.rdoc_options = ["--charset=UTF-8"]
+ s.require_paths = ["lib"]
+ s.rubygems_version = %q{1.3.5}
+ s.summary = %q{Ruby client for unofficial Google Reader API}
+ s.test_files = [
+ "test/helper.rb",
+ "test/test_grapi.rb"
+ ]
+
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<curb>, [">= 0.6.1.0"])
+ s.add_runtime_dependency(%q<nokogiri>, [">= 1.4.1"])
+ s.add_runtime_dependency(%q<loofah>, [">= 0.4.1"])
+ else
+ s.add_dependency(%q<curb>, [">= 0.6.1.0"])
+ s.add_dependency(%q<nokogiri>, [">= 1.4.1"])
+ s.add_dependency(%q<loofah>, [">= 0.4.1"])
+ end
+ else
+ s.add_dependency(%q<curb>, [">= 0.6.1.0"])
+ s.add_dependency(%q<nokogiri>, [">= 1.4.1"])
+ s.add_dependency(%q<loofah>, [">= 0.4.1"])
+ end
+end
+
View
9 test/helper.rb
@@ -0,0 +1,9 @@
+require 'rubygems'
+require 'test/unit'
+
+$LOAD_PATH.unshift(File.dirname(__FILE__))
+$LOAD_PATH.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
+require 'grapi'
+
+class Test::Unit::TestCase
+end
View
7 test/test_grapi.rb
@@ -0,0 +1,7 @@
+require 'helper'
+
+class TestGrapi < Test::Unit::TestCase
+ def test_something_for_real
+ flunk "hey buddy, you should probably rename this file and start testing for real"
+ end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.