Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Pop-up mode in iOS 8 does not close pop-up window #71

Closed
hzalaz opened this Issue Oct 27, 2014 · 8 comments

Comments

Projects
None yet
8 participants
@hzalaz
Copy link
Member

hzalaz commented Oct 27, 2014

From intercom

I’ve been testing using Lock in pop-up mode (which I much prefer because it doesn’t wipe out all the page data with a refresh). It works great in the following:

Windows 8.1 - IE11, Chrome 38

Windows 7 - Firefox 16 (old ‘n’ crappy)

Mac OS X Yosemite - Safari

Windows Phone 8.1 (also IE11)

On both the iOS 8.1 simulators and our iPhone (8.0.2) Safari does not close the pop-up window. I’ve tried a few things but no luck. This would impact the user experience since they’d have no idea (usually) that the window is just hiding the original login page. When I close the window manually, I’m able to hit my API with a token so this is really just a UI/UX issue.

@hzalaz hzalaz added the bug label Oct 27, 2014

@pose

This comment has been minimized.

Copy link
Contributor

pose commented Oct 29, 2014

This is not a Lock issue. This is an auth0-server issue and has been fixed. Thanks! :)

@pose pose closed this Oct 29, 2014

@oskosk

This comment has been minimized.

Copy link

oskosk commented May 5, 2015

I'm still perceiving this issue using lock 7.4 on latest Chrome for iOS. How may I report that to the auth0-server maintainers in case it's still an issue?

@mitya

This comment has been minimized.

Copy link

mitya commented Jun 2, 2015

+1 — the popup is not closed on the latest Chrome for iOS.

@ewelaryba

This comment has been minimized.

Copy link

ewelaryba commented Nov 11, 2015

+1 - I've been seeing this same issue for months.

@will-hancock

This comment has been minimized.

Copy link

will-hancock commented Dec 8, 2015

Is this bug still open? We are experiencing it on a high traffic site and is generating a large quality of Customer Support tickets.

Any info would be greatly appreciated.

gnandretta added a commit that referenced this issue Mar 23, 2016

@michaek

This comment has been minimized.

Copy link

michaek commented May 18, 2016

I'm was seeing this as a current issue for Lock 9.2 in Chrome on iOS, but I updated the installed Chome to version 50, and I am no longer able to reproduce it. Are folks who were seeing this issue able to reproduce with a more recent version of Chrome?

@okonovalenko

This comment has been minimized.

Copy link

okonovalenko commented May 22, 2016

+1 can reproduce on Safari iphone 6 SE, the popup does not go away.

billbonney pushed a commit to billbonney/lock that referenced this issue Jun 4, 2016

@hzalaz hzalaz added the duplicate label Aug 30, 2016

@hzalaz

This comment has been minimized.

Copy link
Member Author

hzalaz commented Aug 30, 2016

Closing in favor of #214

@hzalaz hzalaz closed this Aug 30, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.