Skip to content
Browse files

use dcu-typhoeus since it has lots of bugfixes

Signed-off-by: David A. Cuadrado <krawek@gmail.com>
  • Loading branch information...
1 parent b02df7d commit 2592b186e4d2aeadc1b4ff5615c433df53a510eb @dcu dcu committed May 25, 2012
Showing with 30 additions and 21 deletions.
  1. +2 −2 Gemfile
  2. +19 −12 Gemfile.lock
  3. +1 −1 VERSION
  4. +5 −5 authy.gemspec
  5. +3 −1 lib/authy.rb
View
4 Gemfile
@@ -1,10 +1,10 @@
source "http://rubygems.org"
-gem 'typhoeus', '0.3.3'
-gem 'pry', '0.9.8.1'
+gem 'dcu-typhoeus', :require => 'typhoeus'
group :development do
gem "rspec", "~> 2.8.0"
+ gem 'pry'
gem "yard", "~> 0.7"
gem "rdoc", "~> 3.12"
gem "bundler", "~> 1.1.0"
View
31 Gemfile.lock
@@ -1,22 +1,31 @@
GEM
remote: http://rubygems.org/
specs:
+ activesupport (3.2.3)
+ i18n (~> 0.6)
+ multi_json (~> 1.0)
coderay (1.0.6)
+ dcu-typhoeus (0.4.1)
+ activesupport (~> 3.2)
+ ffi (~> 1.0)
+ mime-types (~> 1.18)
diff-lcs (1.1.3)
+ ffi (1.0.11)
git (1.2.5)
+ i18n (0.6.0)
jeweler (1.8.3)
bundler (~> 1.0)
git (>= 1.2.5)
rake
rdoc
- json (1.6.6)
+ json (1.7.3)
method_source (0.7.1)
mime-types (1.18)
- multi_json (1.3.2)
- pry (0.9.8.1)
+ multi_json (1.3.5)
+ pry (0.9.9.6)
coderay (~> 1.0.5)
- method_source (~> 0.7)
- slop (>= 2.4.3, < 3)
+ method_source (~> 0.7.1)
+ slop (>= 2.4.4, < 3)
rake (0.9.2.2)
rdoc (3.12)
json (~> 1.4)
@@ -38,25 +47,23 @@ GEM
ruby_parser (2.3.1)
sexp_processor (~> 3.0)
sexp_processor (3.2.0)
- simplecov (0.6.2)
- multi_json (~> 1.3)
+ simplecov (0.6.4)
+ multi_json (~> 1.0)
simplecov-html (~> 0.5.3)
simplecov-html (0.5.3)
slop (2.4.4)
- typhoeus (0.3.3)
- mime-types
- yard (0.7.5)
+ yard (0.8.1)
PLATFORMS
ruby
DEPENDENCIES
bundler (~> 1.1.0)
+ dcu-typhoeus
jeweler (~> 1.8.3)
- pry (= 0.9.8.1)
+ pry
rdoc (~> 3.12)
reek (~> 1.2.8)
rspec (~> 2.8.0)
simplecov
- typhoeus (= 0.3.3)
yard (~> 0.7)
View
2 VERSION
@@ -1 +1 @@
-0.0.5
+0.0.6
View
10 authy.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = "authy"
- s.version = "0.0.5"
+ s.version = "0.0.6"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Authy", "David A. Cuadrado"]
- s.date = "2012-05-25"
+ s.date = "2012-05-26"
s.description = "Ruby library to access Authy services"
s.email = "krawek@gmail.com"
s.executables = ["authy-api-console"]
@@ -48,7 +48,7 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<typhoeus>, ["= 0.3.3"])
+ s.add_runtime_dependency(%q<typhoeus>, [">= 0"])
s.add_runtime_dependency(%q<pry>, ["= 0.9.8.1"])
s.add_development_dependency(%q<rspec>, ["~> 2.8.0"])
s.add_development_dependency(%q<yard>, ["~> 0.7"])
@@ -58,7 +58,7 @@ Gem::Specification.new do |s|
s.add_development_dependency(%q<simplecov>, [">= 0"])
s.add_development_dependency(%q<reek>, ["~> 1.2.8"])
else
- s.add_dependency(%q<typhoeus>, ["= 0.3.3"])
+ s.add_dependency(%q<typhoeus>, [">= 0"])
s.add_dependency(%q<pry>, ["= 0.9.8.1"])
s.add_dependency(%q<rspec>, ["~> 2.8.0"])
s.add_dependency(%q<yard>, ["~> 0.7"])
@@ -69,7 +69,7 @@ Gem::Specification.new do |s|
s.add_dependency(%q<reek>, ["~> 1.2.8"])
end
else
- s.add_dependency(%q<typhoeus>, ["= 0.3.3"])
+ s.add_dependency(%q<typhoeus>, [">= 0"])
s.add_dependency(%q<pry>, ["= 0.9.8.1"])
s.add_dependency(%q<rspec>, ["~> 2.8.0"])
s.add_dependency(%q<yard>, ["~> 0.7"])
View
4 lib/authy.rb
@@ -1,7 +1,9 @@
$:.unshift File.expand_path("..", __FILE__)
-require 'json'
+require 'bundler/setup'
+
require 'typhoeus'
+require 'json'
require 'authy/response'
require 'authy/models/user'
require 'authy/config'

0 comments on commit 2592b18

Please sign in to comment.
Something went wrong with that request. Please try again.