popup-create error when trying to trigger auto-complete #254

Open
yhager opened this Issue Sep 11, 2013 · 8 comments

5 participants

@yhager

I have the following in my init.el:

(require 'auto-complete-config)
(add-to-list 'ac-dictionary-directories "~/.emacs.d/lisp/ac-dict")
(ac-config-default)
(ac-set-trigger-key "TAB")

When I press TAB after a typing a few characters, I get the following message:

popup-create: Keyword argument :mouse-face not one of (:min-height :around :face :selection-face :scroll-bar :margin-left :margin-right :symbol :parent :parent-offset)

The full stack trace is at http://paste.lisp.org/display/138903

@yhager

This happened to me with latest auto-complete, and latest popup-el (from its own repo). I downgraded to auto-complete 1.3.1, and now it's working again (but now I'm hit with #48. I'm going to cherry-pick that one)

@yhager yhager closed this Sep 11, 2013
@yhager

sorry, closed by mistake

@yhager yhager reopened this Sep 11, 2013
@djg123

Same problem, but I can't downgrade because I need to use auto-complete-1.

@syohex

@yhager @djyale I can't reproduce this issue and can't get such error message with latest auto-complete
and latest popup-el. Please upgrade these packages version and please report us if you still have this issue.

@nickpascucci

@syohex I'm seeing this as well. Package versions:

auto-complete 20131121.1705
popup 20130708.2245

@syohex

@nickpascucci Thanks. Sorry but I can't reproduce. Please show us code that causes this issue
and tell us how to reproduce this issue.

@nickpascucci

Ok, figured out why I was seeing this. I had an old version of popup.el in my load path shadowing the ELPA version. Removed that and things are working fine now.

@yskmt

The exact same thing happened to me too. I reinstalled popup.el and the problem was resolved. Maybe you should write it out somewhere?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment