Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Auto-complete broken for org mode buffers #289

Closed
Eagleeye777 opened this Issue Jan 31, 2014 · 2 comments

Comments

Projects
None yet
3 participants

I have tried to enable auto-complete with org mode, but it just let's me down completely.

Whenever the pop up menu opens, I am getting the entire screen cluttered with candidates in various faces. Some are readable, some not. Selection does not work at all. Very often I just see three dots ... and some arbitrary letters.

Since I outline most of my Texts there I do need auto-completes functionally primarily in emacs and there it seems like it works the least.

What can I actually do to fix this problem?

Configuration is just pretty standard, just adding org mode after ac-config. Beside that did nothing

zbelial commented Mar 21, 2014

Confirmed here. This only happens when the text "under" the popup menu is outlined. But even no text is outlined, the menu will be not that neat.
I don't know how popup menu and org outline are implemented, maybe the problem is overlay conflict?
ac_in_org

Member

tkf commented Apr 4, 2014

It is a popup.el problem. Should be tracked in auto-complete/popup-el#3 or auto-complete/popup-el#46

@tkf tkf closed this Apr 4, 2014

@kostafey kostafey referenced this issue in kostafey/popup-switcher May 1, 2014

Open

pupup-switcher and org-mode #4

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment