Permalink
Browse files

update dependencies

  • Loading branch information...
josephholsten committed May 14, 2012
1 parent ca89e63 commit 8837b447bdf7eb9670a083a0165900573142b3f0
Showing with 147 additions and 68 deletions.
  1. +0 −4 Gemfile
  2. +140 −54 Gemfile.lock
  3. +7 −10 cucumber-nagios.gemspec
View
@@ -1,7 +1,3 @@
source "http://rubygems.org"
-git "git://github.com/hedgehog/ssh-forever.git", :branch => 'master' do
- gem 'ssh-forever', ">= 0.4.0"
-end
-
gemspec
View
@@ -1,89 +1,175 @@
-GIT
- remote: git://github.com/hedgehog/ssh-forever.git
- revision: 6ea5a2c5fea4829a1952eab3eb1d58cf16269f2b
- branch: master
+PATH
+ remote: ../cuken
specs:
- ssh-forever (0.4.0)
- open4 (>= 1.0.1)
+ cuken (0.1.22)
+ chef (~> 0.10.0)
+ childprocess (>= 0.1.7)
+ cucumber (> 1.0.0)
+ grit (~> 2.4.1)
+ open4
+ rspec
+ rvm (~> 1.8.0)
+ vagrant (~> 0.8.7)
PATH
remote: .
specs:
- cucumber-nagios (0.9.1)
- amqp (= 0.6.7)
- aruba (>= 0.3.3)
- bundler (~> 1.0.10)
- cucumber (>= 0.10.0)
+ cucumber-nagios (0.9.2)
+ amqp (>= 0.6.7)
+ aruba (>= 0.3.4)
+ bundler (>= 1.0.13)
+ cucumber (>= 1.0.1)
cuken (>= 0.1.1)
- mechanize (= 1.0.0)
- net-ssh (~> 2.1.0)
+ mechanize (>= 1.0.0)
+ net-ssh (>= 2.1.4)
rspec (>= 2.5.0)
- ssh-forever (>= 0.4.0)
templater (>= 1.0.0)
- webrat (= 0.7.2)
+ webrat (>= 0.7.2)
GEM
remote: http://rubygems.org/
specs:
- amqp (0.6.7)
- eventmachine (>= 0.12.4)
- aruba (0.3.6)
- childprocess (>= 0.1.7)
- cucumber (>= 0.10.0)
- rspec (>= 2.5.0)
+ amq-client (0.9.2)
+ amq-protocol (>= 0.9.0)
+ eventmachine
+ amq-protocol (0.9.0)
+ amqp (0.9.4)
+ amq-client (~> 0.9.2)
+ amq-protocol (>= 0.9.0)
+ eventmachine
+ archive-tar-minitar (0.5.2)
+ aruba (0.4.11)
+ childprocess (>= 0.2.3)
+ cucumber (>= 1.1.1)
+ ffi (>= 1.0.11)
+ rspec (>= 2.7.0)
builder (3.0.0)
- childprocess (0.1.8)
+ bunny (0.7.9)
+ chef (0.10.8)
+ bunny (>= 0.6.0)
+ erubis
+ highline
+ json (>= 1.4.4, <= 1.6.1)
+ mixlib-authentication (>= 1.1.0)
+ mixlib-cli (>= 1.1.0)
+ mixlib-config (>= 1.1.2)
+ mixlib-log (>= 1.3.0)
+ moneta
+ net-ssh (~> 2.1.3)
+ net-ssh-multi (~> 1.1.0)
+ ohai (>= 0.6.0)
+ rest-client (>= 1.0.4, < 1.7.0)
+ treetop (~> 1.4.9)
+ uuidtools
+ childprocess (0.3.2)
ffi (~> 1.0.6)
- cucumber (0.10.2)
+ cucumber (1.2.0)
builder (>= 2.1.2)
- diff-lcs (>= 1.1.2)
- gherkin (>= 2.3.5)
+ diff-lcs (>= 1.1.3)
+ gherkin (~> 2.10.0)
json (>= 1.4.6)
- term-ansicolor (>= 1.0.5)
- cuken (0.1.1)
- aruba (~> 0.3.3)
- ssh-forever
- diff-lcs (1.1.2)
+ diff-lcs (1.1.3)
+ domain_name (0.5.3)
+ unf (~> 0.0.3)
+ erubis (2.7.0)
eventmachine (0.12.10)
extlib (0.9.15)
- ffi (1.0.7)
- rake (>= 0.8.7)
- gherkin (2.3.6)
+ ffi (1.0.11)
+ gherkin (2.10.0)
json (>= 1.4.6)
- highline (1.6.1)
- json (1.5.1)
- mechanize (1.0.0)
- nokogiri (>= 1.2.1)
+ grit (2.4.1)
+ diff-lcs (~> 1.1)
+ mime-types (~> 1.15)
+ highline (1.6.12)
+ i18n (0.6.0)
+ ipaddress (0.8.0)
+ json (1.5.4)
+ mechanize (2.5)
+ domain_name (~> 0.5, >= 0.5.1)
+ mime-types (~> 1.17, >= 1.17.2)
+ net-http-digest_auth (~> 1.1, >= 1.1.1)
+ net-http-persistent (~> 2.5, >= 2.5.2)
+ nokogiri (~> 1.4)
+ ntlm-http (~> 0.1, >= 0.1.1)
+ webrobots (~> 0.0, >= 0.0.9)
+ mime-types (1.18)
+ mixlib-authentication (1.1.4)
+ mixlib-log
+ mixlib-cli (1.2.2)
+ mixlib-config (1.1.2)
+ mixlib-log (1.3.0)
+ moneta (0.6.0)
+ net-http-digest_auth (1.2)
+ net-http-persistent (2.6)
+ net-scp (1.0.4)
+ net-ssh (>= 1.99.1)
net-ssh (2.1.4)
- nokogiri (1.4.4)
- open4 (1.0.1)
- rack (1.2.2)
- rack-test (0.5.7)
+ net-ssh-gateway (1.1.0)
+ net-ssh (>= 1.99.1)
+ net-ssh-multi (1.1)
+ net-ssh (>= 2.1.4)
+ net-ssh-gateway (>= 0.99.0)
+ nokogiri (1.5.2)
+ ntlm-http (0.1.1)
+ ohai (0.6.12)
+ ipaddress
+ mixlib-cli
+ mixlib-config
+ mixlib-log
+ systemu
+ yajl-ruby
+ open4 (1.3.0)
+ polyglot (0.3.3)
+ rack (1.4.1)
+ rack-test (0.6.1)
rack (>= 1.0)
- rake (0.8.7)
- rspec (2.5.0)
- rspec-core (~> 2.5.0)
- rspec-expectations (~> 2.5.0)
- rspec-mocks (~> 2.5.0)
- rspec-core (2.5.1)
- rspec-expectations (2.5.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.5.0)
+ rake (0.9.2.2)
+ rest-client (1.6.7)
+ mime-types (>= 1.16)
+ rspec (2.10.0)
+ rspec-core (~> 2.10.0)
+ rspec-expectations (~> 2.10.0)
+ rspec-mocks (~> 2.10.0)
+ rspec-core (2.10.0)
+ rspec-expectations (2.10.0)
+ diff-lcs (~> 1.1.3)
+ rspec-mocks (2.10.1)
+ rvm (1.8.6)
+ systemu (2.5.0)
templater (1.0.0)
diff-lcs (>= 1.1.2)
extlib (>= 0.9.5)
highline (>= 1.4.0)
- term-ansicolor (1.0.5)
- webrat (0.7.2)
+ thor (0.14.6)
+ treetop (1.4.10)
+ polyglot
+ polyglot (>= 0.3.1)
+ unf (0.0.5)
+ unf_ext
+ unf_ext (0.0.4)
+ uuidtools (2.1.2)
+ vagrant (0.8.10)
+ archive-tar-minitar (= 0.5.2)
+ erubis (~> 2.7.0)
+ i18n (~> 0.6.0)
+ json (~> 1.5.1)
+ net-scp (~> 1.0.4)
+ net-ssh (~> 2.1.4)
+ thor (~> 0.14.6)
+ virtualbox (~> 0.9.1)
+ virtualbox (0.9.2)
+ ffi (~> 1.0.9)
+ webrat (0.7.3)
nokogiri (>= 1.2.0)
rack (>= 1.0)
rack-test (>= 0.5.3)
+ webrobots (0.0.13)
+ yajl-ruby (1.1.0)
PLATFORMS
ruby
DEPENDENCIES
- aruba (>= 0.3.6)
cucumber-nagios!
+ cuken!
rake (>= 0.8.3)
- ssh-forever (>= 0.4.0)!
View
@@ -16,20 +16,17 @@ Gem::Specification.new do |s|
s.require_paths = ["lib"]
s.files = `git ls-files`.split(/\r?\n\r?/)
s.executables = s.files.grep(/^bin/) { |f| File.basename(f) }
- s.default_executable = "cucumber-nagios"
s.extra_rdoc_files = s.files.grep(/^[A-Z]+(\.md)*$/)
- s.add_runtime_dependency "cucumber", ">= 0.10.0"
+ s.add_runtime_dependency "cucumber", ">= 1.0.1"
s.add_runtime_dependency "rspec", ">= 2.5.0"
- s.add_runtime_dependency "aruba", ">= 0.3.3"
+ s.add_runtime_dependency "aruba", ">= 0.3.4"
s.add_runtime_dependency "cuken", ">= 0.1.1"
- s.add_runtime_dependency "ssh-forever", ">= 0.4.0"
- s.add_runtime_dependency "webrat", "= 0.7.2"
- s.add_runtime_dependency "mechanize", "= 1.0.0"
+ s.add_runtime_dependency "webrat", ">= 0.7.2"
+ s.add_runtime_dependency "mechanize", ">= 1.0.0"
s.add_runtime_dependency "templater", ">= 1.0.0"
- s.add_runtime_dependency "net-ssh", "~> 2.1.0"
- s.add_runtime_dependency "amqp", "= 0.6.7"
- s.add_runtime_dependency "bundler", "~> 1.0.10"
+ s.add_runtime_dependency "net-ssh", ">= 2.1.4"
+ s.add_runtime_dependency "amqp", ">= 0.6.7"
+ s.add_runtime_dependency "bundler", ">= 1.0.13"
s.add_development_dependency "rake", ">= 0.8.3"
- s.add_development_dependency "aruba", ">= 0.3.6"
end

0 comments on commit 8837b44

Please sign in to comment.