Skip to content


Subversion checkout URL

You can clone with
Download ZIP
PHP 5.3 Object Oriented image manipulation library

Merge pull request #461 from romainneutron/fix-454

Fix #254 : Do not read stream more than once
latest commit 84cdc4004f
@romainneutron romainneutron authored


project status Build Status

Tweet about it using the #php_imagine hashtag.

Image manipulation library for PHP 5.3 inspired by Python's PIL and other image libraries.


The Imagine library has the following requirements:

  • PHP 5.3+

Depending on the chosen Image implementation, you may need one of the following:

  • GD2
  • Imagick
  • Gmagick

Installation using composer

php composer.phar require imagine/imagine

Basic Principles

The main purpose of Imagine is to provide all the necessary functionality to bring all native low level image processing libraries in PHP to the same simple and intuitive OO API.

Several things are necessary to accomplish that:

  • Image manipulation tools, such as resize, crop, etc.
  • Drawing API - to create basic shapes and advanced charts, write text on the image
  • Masking functionality - ability to apply black&white or grayscale images as masks, leading to semi-transparency or absolute transparency of the image the mask is being applied to

The above tools should be the basic foundation for a more powerful set of tools that are called Filters in Imagine.

Some of the ideas for upcoming filters:

  • Charting and graphing filters - pie and bar charts, linear graphs with annotations
  • Reflection - apple style
  • Rounded corners - web 2.0




Something went wrong with that request. Please try again.