Skip to content
Permalink
Browse files

upgrade to gradle 2.2.1

  • Loading branch information
avalax committed Dec 3, 2014
1 parent 7c9980f commit 4d33bc3c12af3f95548e61b66e8770769d71db30
@@ -29,4 +29,5 @@ local.properties

# Gradle
.gradle
build/
build/
/gradle-app.setting
@@ -3,9 +3,9 @@ buildscript {
jcenter()
}
dependencies {
classpath 'com.android.tools.build:gradle:0.13.3'
classpath 'com.github.ben-manes:gradle-versions-plugin:0.5'
classpath 'org.robolectric:robolectric-gradle-plugin:0.13.2'
classpath 'com.android.tools.build:gradle:1.0.0-rc1'
classpath 'com.github.ben-manes:gradle-versions-plugin:0.6'
classpath 'org.robolectric:robolectric-gradle-plugin:0.14.1'
classpath 'org.kt3k.gradle.plugin:coveralls-gradle-plugin:2.0.1'
}
}
@@ -56,14 +56,14 @@ android {
buildTypes {
debug {
debuggable true
runProguard false
testCoverageEnabled = true
minifyEnabled false
testCoverageEnabled true
}
if (System.getenv("KEYSTORE") && new File(System.getenv("KEYSTORE")).exists()) {
release {
debuggable false
runProguard true
zipAlign true
minifyEnabled true
zipAlignEnabled true
proguardFiles "proguard.cfg"
signingConfig signingConfigs.release
}
@@ -83,13 +83,13 @@ robolectric {
dependencies {
compile 'com.squareup.dagger:dagger:1.2.2'
compile 'com.jakewharton:butterknife:6.0.0'
compile 'com.android.support:support-v4:21.0.0'
compile 'com.android.support:support-v4:21.0.2'
compile 'com.google.zxing:android-integration:3.1.0'
compile 'com.google.code.gson:gson:2.3'
compile 'com.google.code.gson:gson:2.3.1'
provided 'com.squareup.dagger:dagger-compiler:1.2.2'
androidTestCompile 'junit:junit:4.11'
androidTestCompile 'org.hamcrest:hamcrest-all:1.3'
androidTestCompile 'org.mockito:mockito-all:1.10.8'
androidTestCompile 'org.mockito:mockito-all:1.10.14'
androidTestCompile 'de.bechte.junit:junit-hierarchicalcontextrunner:4.11.3'
androidTestCompile('org.robolectric:robolectric:2.4') {
exclude module: 'classworlds'
@@ -160,4 +160,8 @@ task jacocoTestReport(type: JacocoReport, dependsOn: "testDebug") {
}
}
}
}

task wrapper(type: Wrapper) {
gradleVersion = '2.2.1'
}
Binary file not shown.

This file was deleted.

This file was deleted.

This file was deleted.

Binary file not shown.
@@ -1,6 +1,6 @@
#Wed Apr 10 15:27:10 PDT 2013
#Tue Dec 02 14:30:45 CET 2014
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=http\://services.gradle.org/distributions/gradle-2.1-all.zip
distributionUrl=https\://services.gradle.org/distributions/gradle-2.2.1-all.zip
@@ -1 +1,4 @@
manifest:./AndroidManifest.xml
# Robolectric should use AndroidManifest.xml from $MODULE_DIR$
manifest:./src/main/AndroidManifest.xml
# Robolectric doesn't know how to support SDK 19 yet.
emulateSdk=18

0 comments on commit 4d33bc3

Please sign in to comment.
You can’t perform that action at this time.