Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Successful login sometimes redirects to unexpected pages #2109

Closed
cjcolvar opened this issue Jun 28, 2017 · 4 comments

Comments

Projects
None yet
4 participants
@cjcolvar
Copy link
Member

commented Jun 28, 2017

I'm not sure if I can reproduce this but I signed out in one tab while another was playing audio which had already played through from one section to another. After closing both tabs and going to log back in, Avalon redirected me, but it was an authorize.txt used for streaming authorization. I'm not really sure how or why this happened. This was on neon.

@cjcolvar cjcolvar added the bug 🐛 label Jun 28, 2017

@joncameron

This comment has been minimized.

Copy link
Contributor

commented Jun 28, 2017

@Karthikeya212 can you try to reproduce? I didn't have any success.

@Karthikeya212

This comment has been minimized.

Copy link
Collaborator

commented Jun 29, 2017

I think I had some success, try the below steps in sequence.

  1. Open two tabs of avalon and login in both tabs.
  2. Start playing an item in tab-1.
  3. Go to tab-2 and sign-out of system, but don't close it.
  4. Now go to tab-1 and reload the page, user will be navigated to sign-in page. Sign-in with same credentials.
  5. Now go to tab-2 (do not reload this page) and click on sign-in, user will be redirected (in my case I was redirected to a poster/thumbnail of the video that I was playing in tab-1 earlier).
  6. The only way to login to avalon in this tab is to click on browser back button and refresh the page as clicking on sign-in doesn't navigate to sign-in page.

This redirection might be different depending on the media element type (Audio, Video, Item with both audio & video) that we play in tab-1.

@Karthikeya212

This comment has been minimized.

Copy link
Collaborator

commented Jun 29, 2017

I think this issue is observed even on Embed page yesterday. Embed two items of same server on the embed page, signing in to first item will start playing it, but the second item will still be asking for sign-in. Once we click sign-in on second item it did redirect to the poster of the first video that was playing, but never to sign-in page.

@phuong fixed this on that embed page. Now it is opening a pop-up like for a fraction of second (can't notice if it again opened poster or correctly navigated to sign-in page) and closes it and starts playing the item.

@joncameron

This comment has been minimized.

Copy link
Contributor

commented May 17, 2019

Another edge case bug that only happens when doing a lot of multiple sessions.

@joncameron joncameron closed this May 17, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.