Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Don't use the git format if the 'git' program if older than version 1.6.

  • Loading branch information...
commit 88db35b39b211e89ea8365b1ae047408115ed6b6 1 parent fbcb867
Bruno Haible bhaible authored
Showing with 16 additions and 3 deletions.
  1. +7 −0 gettext-tools/ChangeLog
  2. +9 −3 gettext-tools/configure.ac
7 gettext-tools/ChangeLog
View
@@ -1,3 +1,10 @@
+2010-06-06 Bruno Haible <bruno@clisp.org>
+
+ * configure.ac (ARCHIVE_FORMAT): If neither --with-git nor --with-cvs
+ is specified, don't use the git format if the 'git' program if older
+ than version 1.6.
+ Suggested by Karl Berry <karl@freefriends.org>.
+
2010-06-04 Bruno Haible <bruno@clisp.org>
* gettext-0.18.1 released.
12 gettext-tools/configure.ac
View
@@ -338,9 +338,15 @@ else
ARCHIVE_FORMAT=cvs
else
# Neither --with-git nor --with-cvs is specified.
- if test "$gt_use_git" != no && (git --version) >/dev/null 2>&1; then
- # --without-git is not specified, and the git program exists.
- # Use git format.
+ if test "$gt_use_git" != no \
+ && (git --version) >/dev/null 2>&1 \
+ && { case `git --version | sed -e 's/^[^0-9]*//'` in
+ 0.* | 1.[0-5].*) false ;;
+ *) true ;;
+ esac
+ }; then
+ # --without-git is not specified, and the git program exists
+ # in version 1.6 or newer. Use git format.
ARCHIVE_FORMAT=git
else
# --without-git is specified, or the git program is missing.
Please sign in to comment.
Something went wrong with that request. Please try again.