Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
tree: 49867558a3
Fetching contributors…

Cannot retrieve contributors at this time

42 lines (37 sloc) 1.996 kb
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{bj}
s.version = "1.0.2"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Ara T. Howard (ara.t.howard@noaa.gov)", "Daniel Hahn (JRuby modifications)"]
s.date = %q{2009-09-11}
s.default_executable = %q{bj}
s.description = %q{Special version for JRuby compatibility. Backgroundjob (Bj) is a brain dead simple zero admin background priority queue for Rails. Bj is robust, platform independent (including windows), and supports internal or external manangement of the background runner process.}
s.email = %q{hahn@netseven.it}
s.executables = ["bj"]
s.extra_rdoc_files = ["README"]
s.files = ["VERSION.yml", "bin/bj", "lib/bj", "lib/bj/api.rb", "lib/bj/attributes.rb", "lib/bj/bj.rb", "lib/bj/errors.rb", "lib/bj/joblist.rb", "lib/bj/logger.rb", "lib/bj/runner.rb", "lib/bj/stdext.rb", "lib/bj/table.rb", "lib/bj/util.rb", "lib/bj.rb", "README"]
s.has_rdoc = true
s.homepage = %q{http://codeforpeople.com/lib/ruby/}
s.rdoc_options = ["--inline-source", "--charset=UTF-8"]
s.require_paths = ["lib"]
s.rubygems_version = %q{1.3.1}
s.summary = %q{Backgroundjob}
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 2
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<main>, [">= 2.6.0"])
s.add_runtime_dependency(%q<averell23-systemu>, [">= 1.2.0"])
s.add_runtime_dependency(%q<orderedhash>, [">= 0.0.3"])
else
s.add_dependency(%q<main>, [">= 2.6.0"])
s.add_dependency(%q<averell23-systemu>, [">= 1.2.0"])
s.add_dependency(%q<orderedhash>, [">= 0.0.3"])
end
else
s.add_dependency(%q<main>, [">= 2.6.0"])
s.add_dependency(%q<averell23-systemu>, [">= 1.2.0"])
s.add_dependency(%q<orderedhash>, [">= 0.0.3"])
end
end
Jump to Line
Something went wrong with that request. Please try again.