New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Loosen requests dependency #13

Merged
merged 1 commit into from Oct 15, 2017

Conversation

Projects
None yet
3 participants
@tony
Copy link
Contributor

tony commented Oct 11, 2017

Fixes issues with Pipfile dependency resolution/locking

venv ❯ pipenv install -r requirements/base.txt
Courtesy Notice: Pipenv found itself running within a virtual environment, so it will automatically use that environment, instead of creating its own for any project.
Creating a Pipfile for this project…
Requirements file provided! Importing into Pipfile…
Pipfile.lock not found, creating…
Locking [dev-packages] dependencies…
Locking [packages] dependencies…
Warning: Your dependencies could not be resolved. You likely have a mismatch in your sub-dependencies.
  You can use $ pipenv install --skip-lock to bypass this mechanism, then run $ pipenv graph to inspect the situation.
Could not find a version that matches requests==2.13.0,==2.18.4,>=2.0.0,>=2.4.3
Tried: 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4, 0.3.0, 0.3.1, 0.3.2, 0.3.3, 0.3.4, 0.4.0, 0.4.1, 0.5.0, 0.5.1, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.6.6, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.7.5, 0.7.6, 0.8.0, ...
Loosen requests dependency
Fixes issues with Pipfile dependency resolution/locking
@coveralls

This comment has been minimized.

Copy link

coveralls commented Oct 11, 2017

Coverage Status

Coverage remained the same at 88.421% when pulling f12c1f7 on develtech:requests-version into 2dce6cb on avinassh:master.

@tony

This comment has been minimized.

Copy link
Contributor Author

tony commented Oct 12, 2017

@avinassh any idea on this? I'm running a forked package atm to get Pipfile dependency resolution working.

@avinassh

This comment has been minimized.

Copy link
Owner

avinassh commented Oct 13, 2017

@tony I can install requests==2.13.0 without any issues. and same is available on pypi too - https://pypi.python.org/pypi/requests/2.13.0

@tony

This comment has been minimized.

Copy link
Contributor Author

tony commented Oct 13, 2017

How can you install a package requests 2.13.0 on pipenv if you have other packages asking for requests that conflict with exactly 2.13.0?

If you don't believe me, I'll show you the pipenv graph.

(pipenv != pip, it has dependency resolution/graphing)

Is there a reason it's only 2.13.0 and not 2.0.0>=?

@avinassh

This comment has been minimized.

Copy link
Owner

avinassh commented Oct 15, 2017

I have not used pipenv earlier.

Is there a reason it's only 2.13.0 and not 2.0.0>=?

I just like use fixed version pinning. However I am merging this for now 👍

@avinassh avinassh merged commit 9dbd6fb into avinassh:master Oct 15, 2017

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@tony

This comment has been minimized.

Copy link
Contributor Author

tony commented Oct 19, 2017

can you release this on pipit @avinassh ?

@tony tony deleted the develtech:requests-version branch Oct 19, 2017

@tony tony restored the develtech:requests-version branch Oct 19, 2017

@avinassh

This comment has been minimized.

Copy link
Owner

avinassh commented Nov 14, 2017

Hey sorry for late reply, I somehow I did not get the notification for the last comment. I just made a new release - https://pypi.org/project/haxor/0.6/

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment