Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Sketch Plugin Black Screen #1333

Closed
Dang-Dango opened this issue Mar 20, 2017 · 7 comments
Closed

Sketch Plugin Black Screen #1333

Dang-Dango opened this issue Mar 20, 2017 · 7 comments
Assignees

Comments

@Dang-Dango
Copy link

@Dang-Dango Dang-Dango commented Mar 20, 2017

zrzut ekranu 2017-03-20 o 09 48 50

zrzut ekranu 2017-03-20 o 09 53 30

  • Version:
    Avocode plugin 42.0.0
  • Native/Web:
    Native
  • Platform:
    Mac/Sketch
@Vashiru
Copy link

@Vashiru Vashiru commented Mar 20, 2017

Looks like the same issue as I had. As a workaround for now:

  1. Open Sketch
  2. Go to Plugins -> Manage plugins -> In the bottom left corner press the gear icon -> Show plugins folder
  3. Delete avocode-token.json
  4. Restart Sketch
  5. Next time you start Avocode plugin it will ask you to sign in again, once you do Avocode will work as intended.

Loading

@connor-bean
Copy link

@connor-bean connor-bean commented Mar 21, 2017

Thanks for the comment @Vashiru.

@Dang-Dango - did this workaround work for you too>

Loading

@Dang-Dango
Copy link
Author

@Dang-Dango Dang-Dango commented Mar 21, 2017

Deleting the .json file works like a charm. Thanks for the help.

Loading

@Dang-Dango Dang-Dango closed this Mar 21, 2017
@Vashiru
Copy link

@Vashiru Vashiru commented Mar 21, 2017

This issue does keep returning for me though, so I wouldn't close it right now

Loading

@bolekkerous bolekkerous reopened this Mar 21, 2017
@1854
Copy link

@1854 1854 commented Apr 11, 2017

Im stuck on loading screen, am using sketch 43.1, followed steps above, i see sketch-panels.log but avocode-token.json is not in the plugins folder, am using sketch-plugin-mac-42.0.0 (made the switch from invision yesterday)

Loading

@bolekkerous
Copy link

@bolekkerous bolekkerous commented Apr 12, 2017

This might be a DNS problem, @1854 .

There are 3 possible things that you could try:

  1. Try opening up https://sourcelocalhost.com:33162 in browser while the plugin screen is loading (it's where the plugin lives), maybe it will work in the browser if the error is isolated to Sketch.
  2. Try Google DNS if possible
  3. Add the DNS entry 127.0.0.1 sourcelocalhost.com to /etc/hosts manually

Here's an article explaining more about the host file:
http://www.imore.com/how-edit-your-macs-hosts-file-and-why-you-would-want

Please let us know the result.

Loading

@jakubzitny jakubzitny assigned jakubzitny and unassigned rychlis Jun 14, 2017
@connor-bean
Copy link

@connor-bean connor-bean commented Jun 15, 2017

Hey this is now fixed in 2.14.3 with the new plugin. Please update your app

Loading

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
7 participants