Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bad rendering of psd clipping mask of layers with different sizes #253

Closed
helloiamvu opened this issue May 15, 2015 · 6 comments

Comments

Projects
None yet
4 participants
@helloiamvu
Copy link

commented May 15, 2015

Web (PSD): screenshot 2015-05-15 14 58 09
App: capture image

@rychlis rychlis added the bug label Jul 28, 2015

@rychlis

This comment has been minimized.

Copy link
Member

commented Jul 28, 2015

This seems to be related to rendering clipping mask of layers with different sizes. We can still reproduce this in latest version (2.3.2).

@rychlis rychlis added the onGitlab label Jul 28, 2015

@rychlis rychlis changed the title The icon looks different in the app and on Avocode.com Bad rendering of psd clipping mask of layers with different sizes Oct 23, 2015

@n0rule5

This comment has been minimized.

Copy link

commented Dec 3, 2015

Is this issue (and #432) actively being worked on? I have a lot of layers that uses clipping masks and they're rendered incorrectly or completely missing from the layers panel. I'm using version 2.4.5

@blorenz

This comment has been minimized.

Copy link

commented Feb 6, 2016

Clipping masks are still an issue and a PITA with Avocode.

@n0rule5

This comment has been minimized.

Copy link

commented Feb 10, 2016

I would consider this bug major/critical and yet it's still not fixed. The clipped layers are converted so badly, at best the clipped layers are shifted around and randomly cut off, and at worst it renders other layers inside the mask. Here's an example: The grey background for the title is clipped to the white box with rounded corners, but gets shifted when converted into Avocode for inspection.

image
image

@blorenz

This comment has been minimized.

Copy link

commented Feb 16, 2016

Can we get this issue opened, @rychlis? There is significant difference in an actual PSD that uses clipping masks to what Avocode outputs to the point that Avocode is only useful in very limited capacity.

@rychlis

This comment has been minimized.

Copy link
Member

commented Feb 18, 2016

yes in fact we've just released Avocode 2.6.0 that should fix this issue. Thanks for reporting!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.