Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Avocode 2.4.5 installer failing #521

Closed
VPenkov opened this issue Nov 12, 2015 · 21 comments

Comments

Projects
None yet
8 participants
@VPenkov
Copy link

commented Nov 12, 2015

image

I had a fresh Windows reinstall yesterday. My 2.4.3 Avocode is working but the new one isn't. Don't know where I can view the setup log.

@VPenkov

This comment has been minimized.

Copy link
Author

commented Nov 12, 2015

After some digging, it looks like it actually installed to
C:\Users\MyUserName\AppData\Local\avocode\app-2.4.5

The 2.4.4 and 2.4.3 versions are there as well. So the install probably fails at its end.

@petrbrzek

This comment has been minimized.

Copy link
Member

commented Nov 12, 2015

I'm not able to reproduce the issue. Does this also happen if you uninstall Avocode and then install it again?

@VPenkov

This comment has been minimized.

Copy link
Author

commented Nov 12, 2015

Yes. While we're at it, you should add a confirmation dialog to the uninstall wizard.
It actually does manage to install itself but shows an error and fails to create any shortcuts.

I tried re-downloading the package and got the same result.

@mark-reason

This comment has been minimized.

Copy link

commented Nov 13, 2015

I had the same issue, had the error but has installed.

@spa

This comment has been minimized.

Copy link

commented Nov 13, 2015

Same issue: received the install error, and found that it actually did install into C:\Users\MyUserName\AppData\Local\avocode\app-2.4.5

@rychlis

This comment has been minimized.

Copy link
Member

commented Nov 13, 2015

Hi the log file should be located in the C:\Users\MyUserName\AppData\Local\avocode\SquirrelSetup.log

The problem is that every launch of Avocode will overwrite this log file so we need you to launch the installer again and send us the log after it fails if you can.

It might be related to Squirrel/Squirrel.Windows#322 which is fixed but we are not using the new version yet

@VPenkov

This comment has been minimized.

Copy link
Author

commented Nov 13, 2015

I'm getting no such file.
I used to have it but then you had me uninstall Avocode. I did have a look though, and it had some old stuff there.

I tried to create it manually, but that didn't help.

@rychlis

This comment has been minimized.

Copy link
Member

commented Nov 13, 2015

Do you have Group Policy restrictions enabled on your machine by any chance? See the last paragraph Enterprise environments and Group Policy

Try running Setup.exe from %LocalAppData%\SquirrelTemp like in the troubleshooting guide

@VPenkov

This comment has been minimized.

Copy link
Author

commented Nov 13, 2015

Yeah, there's no setup.exe there but look what I found. A wild SquirrelSetup.log appears...
http://pastebin.com/Tz5wDwM1

PS: it was the only file in there.

@rychlis

This comment has been minimized.

Copy link
Member

commented Nov 13, 2015

--- (Inner Exception #0) System.OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown.

ok it seems like your system went out of memory based on the log. How much free memory do you have?

Anyways here is a link to a zip version of avocode without installer: https://manager.avocode.com/download/avocode-app/windows-zip/

@VPenkov

This comment has been minimized.

Copy link
Author

commented Nov 13, 2015

I've got 8 gigs and I'm nowhere near running out of memory.
I'm reaching about 65% while the installer is doing its things.

Should I clear my log and run it again?
Edit: done - http://pastebin.com/n3B2jzHp

While running the installer, I saw it create the .exe files but then it cleaned up after itself and this was left with the log (which was the only file left).

Also, no uninstall was created this time.

@rychlis

This comment has been minimized.

Copy link
Member

commented Nov 13, 2015

Ok it's probably this issue: Squirrel/Squirrel.Windows#309

Seems like it's a bug in NuGet library used by Squirrel.Windows library used by Avocode (and numerous other projects). You can use the zip link until they or we find a fix

@mark-reason @spa could you also look into %LocalAppData%\SquirrelTemp\ if there is a squirell log to confirm this is the same issue? If it's not there it might also be in %LocalAppData%\avocode\

@spa

This comment has been minimized.

Copy link

commented Nov 13, 2015

Looks my log is similar: http://pastebin.com/jvHMpd1K

@VPenkov

This comment has been minimized.

Copy link
Author

commented Nov 16, 2015

When can we expect a fix?

I don't reckon we'd get an update notification inside Avocode, correct? It doesn't run through update.exe anymore.

@rychlis

This comment has been minimized.

Copy link
Member

commented Nov 19, 2015

@VPenkov update.exe is not needed for update notifications, in-app update notifications are implemented universally for all platforms so they will work even in the zip version.

I am not sure when to expect a fix, we will at least add a zip link to the download page for now. We are not able to reproduce this on our windows machines so it's hard to fix for us at the moment :(

According to the Squirrel issue they are going to replace the buggy NuGet implementation with a different one which is the best solution but there is no ETA on that.

Based on the Squirrel issue the problem happens when there is a big file archive like our resources/app.asar. The weird thing is that in 2.4.5 this file is actually smaller than in 2.4.3 and it seems that people didn't bump into this issue with 2.4.3. We'll definetely try to investigate this further

@VPenkov

This comment has been minimized.

Copy link
Author

commented Nov 19, 2015

Yep, 2.4.3 didn't have this. I'm inclined to provide remote desktop access to investigate the issue. Hit me up at vergil@moongrab.com (and use an @avocode.com mail if you do so) if you could make use of that.

@rychlis

This comment has been minimized.

Copy link
Member

commented Nov 19, 2015

Actually I was looking into wrong folder and the 2.4.5 windows asar is in fact larger than in 2.4.3. That's weird because on linux/osx the asar is a lot smaller in 2.4.5. There is probably a build process problem on windows, we'll try to fix it

@MazheM

This comment has been minimized.

Copy link

commented Nov 20, 2015

I have the same error on install, but i can run Avocode.exe from folder and its runs.

@martynas-m

This comment has been minimized.

Copy link

commented Dec 17, 2015

the same there, error on install, but still can find and run it from AppData\local and run it.

@mvaldas9

This comment has been minimized.

Copy link

commented Jan 4, 2016

error on install, can find and run avocode from Appdata...

@rychlis

This comment has been minimized.

Copy link
Member

commented Jan 26, 2016

This error should be now fixed with the latest Avocode 2.5.2. Sorry it took so long!

@rychlis rychlis closed this Jan 26, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.