New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Connection error #960

Closed
katjabruhn opened this Issue Jul 4, 2016 · 14 comments

Comments

Projects
None yet
6 participants
@katjabruhn

katjabruhn commented Jul 4, 2016

Hello, after synchronizing my Sketch file with Avocode I would open the artboards in Avocode, but I always get a connection error / download error. What can I do? I have the latest Avocode version and the latest sketch plugin (3.7).

Please, can you help me.

@connor-bean

This comment has been minimized.

Show comment
Hide comment
@connor-bean

connor-bean Jul 4, 2016

Hey, Katja -

Can you send us a screenshot of the error you're seeing? What OS are you running? And are you running Sketch Beta?

Thanks,
Connor, Avocode Support

connor-bean commented Jul 4, 2016

Hey, Katja -

Can you send us a screenshot of the error you're seeing? What OS are you running? And are you running Sketch Beta?

Thanks,
Connor, Avocode Support

@katjabruhn

This comment has been minimized.

Show comment
Hide comment
@katjabruhn

katjabruhn Jul 4, 2016

Hey Connor,

I am sending you the requested error messages. I’m running OS X El Capitan Version 10.11.2 and Sketch Version 3.8.3.

Best regards,
Katja

katjabruhn commented Jul 4, 2016

Hey Connor,

I am sending you the requested error messages. I’m running OS X El Capitan Version 10.11.2 and Sketch Version 3.8.3.

Best regards,
Katja

@connor-bean

This comment has been minimized.

Show comment
Hide comment
@connor-bean

connor-bean Jul 4, 2016

Hey, Katja -

Can you try resending the screenshots? Or send them to team@avocode.com? I don't see them in Github.

Thanks!
Connor, Avocode Support

connor-bean commented Jul 4, 2016

Hey, Katja -

Can you try resending the screenshots? Or send them to team@avocode.com? I don't see them in Github.

Thanks!
Connor, Avocode Support

@katjabruhn

This comment has been minimized.

Show comment
Hide comment
@katjabruhn

katjabruhn Jul 5, 2016

Hey Connor,
here are the screenshots:

bildschirmfoto 2016-07-04 um 15 33 30
bildschirmfoto 2016-07-04 um 15 33 33

katjabruhn commented Jul 5, 2016

Hey Connor,
here are the screenshots:

bildschirmfoto 2016-07-04 um 15 33 30
bildschirmfoto 2016-07-04 um 15 33 33

@vojtatranta

This comment has been minimized.

Show comment
Hide comment
@vojtatranta

vojtatranta Jul 5, 2016

Hi @katjabruhn,
can you for example drag and drop a .psd into Avocode to find out whether it is just a problem of sketch?

vojtatranta commented Jul 5, 2016

Hi @katjabruhn,
can you for example drag and drop a .psd into Avocode to find out whether it is just a problem of sketch?

@katjabruhn

This comment has been minimized.

Show comment
Hide comment
@katjabruhn

katjabruhn Jul 5, 2016

Hi @vojtatranta , it seems to be just a problem with sketch-files. I tested it with a psd file and it works. But is the attached message may be related to this problem?
bildschirmfoto 2016-07-05 um 13 48 19

katjabruhn commented Jul 5, 2016

Hi @vojtatranta , it seems to be just a problem with sketch-files. I tested it with a psd file and it works. But is the attached message may be related to this problem?
bildschirmfoto 2016-07-05 um 13 48 19

@vojtatranta

This comment has been minimized.

Show comment
Hide comment
@vojtatranta

vojtatranta Jul 5, 2016

@katjabruhn aha, I see, what version of Sketch and Avocode Sketch Extension do you use?

vojtatranta commented Jul 5, 2016

@katjabruhn aha, I see, what version of Sketch and Avocode Sketch Extension do you use?

@katjabruhn

This comment has been minimized.

Show comment
Hide comment
@katjabruhn

katjabruhn Jul 5, 2016

sketch version 3.8.3
avocode sketch plugin versions 3.7

katjabruhn commented Jul 5, 2016

sketch version 3.8.3
avocode sketch plugin versions 3.7

@connor-bean

This comment has been minimized.

Show comment
Hide comment
@connor-bean

connor-bean Jul 5, 2016

Hey, @katjabruhn -

Can you send us the problematic design to team@avocode.com?

Thanks,
Connor, Avocode Support

connor-bean commented Jul 5, 2016

Hey, @katjabruhn -

Can you send us the problematic design to team@avocode.com?

Thanks,
Connor, Avocode Support

@connor-bean connor-bean added onGitlab and removed onGitlab labels Jul 8, 2016

@connor-bean connor-bean closed this Jul 8, 2016

@katjabruhn

This comment has been minimized.

Show comment
Hide comment
@katjabruhn

katjabruhn Jul 8, 2016

Hello, I uninstalled sketch and installed it again. I synced the Sketch file with Avocode and then the following error occurred. Can you now see what's causing the error?

IMPORTANT: Please try to describe how did it happen.


App v.2.8.4
Source UID: 17351

Error: Could not call remote function 'quit'. Check that the function signature is correct. Underlying error: Attempting to call a function in a renderer window that has been closed or released. Function provided here: avocode.min.js:23:13547.
Error: Could not call remote function 'quit'. Check that the function signature is correct. Underlying error: Attempting to call a function in a renderer window that has been closed or released. Function provided here: avocode.min.js:23:13547.
    at callFunction (/Applications/Avocode.app/Contents/Resources/electron.asar/browser/rpc-server.js:222:11)
    at EventEmitter.<anonymous> (/Applications/Avocode.app/Contents/Resources/electron.asar/browser/rpc-server.js:303:5)
    at emitMany (events.js:127:13)
    at EventEmitter.emit (events.js:201:7)
    at EventEmitter.<anonymous> (/Applications/Avocode.app/Contents/Resources/electron.asar/browser/api/web-contents.js:165:13)
    at emitTwo (events.js:106:13)
    at EventEmitter.emit (events.js:191:7)
    at metaToValue (/Applications/Avocode.app/Contents/Resources/electron.asar/renderer/api/remote.js:178:13)
    at remoteMemberFunction (/Applications/Avocode.app/Contents/Resources/electron.asar/renderer/api/remote.js:112:18)
    at t.quit (file:///Applications/Avocode.app/Contents/Resources/app.asar/dist/avocode.min.js:2:7270)
    at a.call.concat.click (file:///Applications/Avocode.app/Contents/Resources/app.asar/dist/avocode.min.js:25:14416)
    at CallbacksRegistry.apply (/Applications/Avocode.app/Contents/Resources/electron.asar/common/api/callbacks-registry.js:54:39)
    at EventEmitter.<anonymous> (/Applications/Avocode.app/Contents/Resources/electron.asar/renderer/api/remote.js:243:21)
    at emitThree (events.js:116:13)
    at EventEmitter.emit (events.js:194:7)

katjabruhn commented Jul 8, 2016

Hello, I uninstalled sketch and installed it again. I synced the Sketch file with Avocode and then the following error occurred. Can you now see what's causing the error?

IMPORTANT: Please try to describe how did it happen.


App v.2.8.4
Source UID: 17351

Error: Could not call remote function 'quit'. Check that the function signature is correct. Underlying error: Attempting to call a function in a renderer window that has been closed or released. Function provided here: avocode.min.js:23:13547.
Error: Could not call remote function 'quit'. Check that the function signature is correct. Underlying error: Attempting to call a function in a renderer window that has been closed or released. Function provided here: avocode.min.js:23:13547.
    at callFunction (/Applications/Avocode.app/Contents/Resources/electron.asar/browser/rpc-server.js:222:11)
    at EventEmitter.<anonymous> (/Applications/Avocode.app/Contents/Resources/electron.asar/browser/rpc-server.js:303:5)
    at emitMany (events.js:127:13)
    at EventEmitter.emit (events.js:201:7)
    at EventEmitter.<anonymous> (/Applications/Avocode.app/Contents/Resources/electron.asar/browser/api/web-contents.js:165:13)
    at emitTwo (events.js:106:13)
    at EventEmitter.emit (events.js:191:7)
    at metaToValue (/Applications/Avocode.app/Contents/Resources/electron.asar/renderer/api/remote.js:178:13)
    at remoteMemberFunction (/Applications/Avocode.app/Contents/Resources/electron.asar/renderer/api/remote.js:112:18)
    at t.quit (file:///Applications/Avocode.app/Contents/Resources/app.asar/dist/avocode.min.js:2:7270)
    at a.call.concat.click (file:///Applications/Avocode.app/Contents/Resources/app.asar/dist/avocode.min.js:25:14416)
    at CallbacksRegistry.apply (/Applications/Avocode.app/Contents/Resources/electron.asar/common/api/callbacks-registry.js:54:39)
    at EventEmitter.<anonymous> (/Applications/Avocode.app/Contents/Resources/electron.asar/renderer/api/remote.js:243:21)
    at emitThree (events.js:116:13)
    at EventEmitter.emit (events.js:194:7)

@connor-bean connor-bean reopened this Jul 8, 2016

@rychlis rychlis removed their assignment Jul 8, 2016

@greystate

This comment has been minimized.

Show comment
Hide comment
@greystate

greystate Jul 12, 2016

I'm seeing the "Connection error" problems too with a specific Sketch file today (I've sent it to team@avocode.com)

greystate commented Jul 12, 2016

I'm seeing the "Connection error" problems too with a specific Sketch file today (I've sent it to team@avocode.com)

@greystate

This comment has been minimized.

Show comment
Hide comment
@greystate

greystate Aug 5, 2016

Just to keep you updated - I still have this problem for that specific design, in Avocode 2.9.1

greystate commented Aug 5, 2016

Just to keep you updated - I still have this problem for that specific design, in Avocode 2.9.1

This was referenced Aug 8, 2016

@jimmi-joensson

This comment has been minimized.

Show comment
Hide comment
@jimmi-joensson

jimmi-joensson Sep 22, 2016

Got the same connection error running Avocode on Ubuntu 16.04, however found out that it was a permission problem by reading the error message below. Avocode wasn't allowed to create a folder in my system.

Solved the problem by running the app as administrator, hope this helps somebody else.


App v. 2.10.1
Source UID: 82781

Error: EACCES: permission denied, mkdir '/home/user/.avocode/userdata/82781/documents/7de5c04a52dd4cdfad2cd0ec3260f4e0'
    at Error (native)
    at Object.fs.mkdirSync (fs.js:922:18)
    at Function.sync (/opt/avocode/resources/app.asar/node_modules/fs-plus/node_modules/mkdirp/index.js:55:12)
    at Object.makeTreeSync (/opt/avocode/resources/app.asar/node_modules/fs-plus/lib/fs-plus.js:372:23)
    at e.exports.e.ensureDirectory (file:///opt/avocode/resources/app.asar/dist/avocode.min.js:16:20787)
    at e._downloadRevisionMetadata (file:///opt/avocode/resources/app.asar/dist/avocode.min.js:14:5579)
    at e._downloadDesignRevision (file:///opt/avocode/resources/app.asar/dist/avocode.min.js:14:5389)
    at e._downloadRevision (file:///opt/avocode/resources/app.asar/dist/avocode.min.js:14:3877)
    at file:///opt/avocode/resources/app.asar/dist/avocode.min.js:14:3352
    at e._processRevision (file:///opt/avocode/resources/app.asar/dist/avocode.min.js:24:29152)
    at e._processRevisi

jimmi-joensson commented Sep 22, 2016

Got the same connection error running Avocode on Ubuntu 16.04, however found out that it was a permission problem by reading the error message below. Avocode wasn't allowed to create a folder in my system.

Solved the problem by running the app as administrator, hope this helps somebody else.


App v. 2.10.1
Source UID: 82781

Error: EACCES: permission denied, mkdir '/home/user/.avocode/userdata/82781/documents/7de5c04a52dd4cdfad2cd0ec3260f4e0'
    at Error (native)
    at Object.fs.mkdirSync (fs.js:922:18)
    at Function.sync (/opt/avocode/resources/app.asar/node_modules/fs-plus/node_modules/mkdirp/index.js:55:12)
    at Object.makeTreeSync (/opt/avocode/resources/app.asar/node_modules/fs-plus/lib/fs-plus.js:372:23)
    at e.exports.e.ensureDirectory (file:///opt/avocode/resources/app.asar/dist/avocode.min.js:16:20787)
    at e._downloadRevisionMetadata (file:///opt/avocode/resources/app.asar/dist/avocode.min.js:14:5579)
    at e._downloadDesignRevision (file:///opt/avocode/resources/app.asar/dist/avocode.min.js:14:5389)
    at e._downloadRevision (file:///opt/avocode/resources/app.asar/dist/avocode.min.js:14:3877)
    at file:///opt/avocode/resources/app.asar/dist/avocode.min.js:14:3352
    at e._processRevision (file:///opt/avocode/resources/app.asar/dist/avocode.min.js:24:29152)
    at e._processRevisi
@connor-bean

This comment has been minimized.

Show comment
Hide comment
@connor-bean

connor-bean Jun 15, 2017

Hey this is now fixed in 2.14.3. Please update your app

connor-bean commented Jun 15, 2017

Hey this is now fixed in 2.14.3. Please update your app

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment