Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 49 lines (43 sloc) 1.949 kB
3050c8c @avsej Initial implementation. GET/SET support
authored
1 # -*- encoding: utf-8 -*-
2 # Author:: Couchbase <info@couchbase.com>
3 # Copyright:: 2011, 2012 Couchbase, Inc.
4 # License:: Apache License, Version 2.0
5 #
6 # Licensed under the Apache License, Version 2.0 (the "License");
7 # you may not use this file except in compliance with the License.
8 # You may obtain a copy of the License at
9 #
10 # http://www.apache.org/licenses/LICENSE-2.0
11 #
12 # Unless required by applicable law or agreed to in writing, software
13 # distributed under the License is distributed on an "AS IS" BASIS,
14 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
15 # See the License for the specific language governing permissions and
16 # limitations under the License.
17 #
18
19 $:.push File.expand_path('../lib', __FILE__)
20 require 'em-couchbase/version'
21
22 Gem::Specification.new do |s|
23 s.name = 'em-couchbase'
24 s.version = EventMachine::Protocols::Couchbase::VERSION
25 s.author = 'Couchbase'
26 s.email = 'support@couchbase.com'
27 s.license = 'ASL-2'
28 s.homepage = 'http://couchbase.org'
29 s.summary = %q{An EventMachine-based Couchbase ruby driver}
30 s.description = %q{The official client library built atop of EventMachine for use with Couchbase Server.}
31
32 s.files = `git ls-files`.split("\n")
33 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
34 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
35 s.extensions = `git ls-files -- ext/**/extconf.rb`.split("\n")
36 s.require_paths = ['lib']
37
38 s.add_runtime_dependency 'yajl-ruby', '~> 1.1.0'
a6b1c1d @avsej Use eventmachine-le
authored
39 # to use fixes from eventmachine master branch
d31f3a2 @avsej catch connection timeouts for HTTP listener
authored
40 s.add_runtime_dependency 'eventmachine-le', '~> 1.1.0'
3050c8c @avsej Initial implementation. GET/SET support
authored
41 s.add_runtime_dependency 'em-http-request', '~> 1.0.1'
42
43 s.add_development_dependency 'rake', '~> 0.8.7'
44 s.add_development_dependency 'minitest'
45 s.add_development_dependency 'rdiscount'
46 s.add_development_dependency 'yard'
ae0c46e @avsej Use debugger gem instead of legacy ruby-debug
authored
47 s.add_development_dependency 'debugger'
3050c8c @avsej Initial implementation. GET/SET support
authored
48 end
Something went wrong with that request. Please try again.