Permalink
Browse files

Use eventmachine-le

  • Loading branch information...
1 parent 6869e7d commit a6b1c1db6593e55cf66b66fff16eee7e4962000c @avsej committed Mar 23, 2012
Showing with 2 additions and 0 deletions.
  1. +1 −0 em-couchbase.gemspec
  2. +1 −0 lib/em-couchbase.rb
View
@@ -36,6 +36,7 @@ Gem::Specification.new do |s|
s.require_paths = ['lib']
s.add_runtime_dependency 'yajl-ruby', '~> 1.1.0'
+ # to use fixes from eventmachine master branch
@ibc

ibc Mar 23, 2012

Hi, to be honest, EventMachine-LE is not EventMachine master branch. EventMachine-LE incorporates lot of fixes and pull requests that EM master just ignores for months/years.

For example, EventMachine-LE completely supports IPv6 (for UDP and TCP in both client and server mode). This big improvement does NOT exist in EventMachine master branch.

s.add_runtime_dependency 'eventmachine-le', '~> 1.1.0'
s.add_runtime_dependency 'em-http-request', '~> 1.0.1'
View
@@ -17,6 +17,7 @@
require 'em-couchbase/version'
require 'yajl/json_gem'
+# to use fixes from eventmachine master branch
require 'eventmachine-le'
require 'em-http'
require 'uri'

0 comments on commit a6b1c1d

Please sign in to comment.