Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Development Studio for OCaml
OCaml Perl Emacs Lisp C
tree: ac13e31f08

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
boot
docs/user-manual
emacs-plugins
libs
m4
ocaml
tools
.gitignore
.typerex
AUTHORS
Changelog.txt
LICENSE.OCaml
LICENSE.Profile
LICENSE.TypeRex
LICENSE.lgpl2+linking_exception
Makefile
Makefile.config.in
README
configure
configure.ac
emacs.append.in
ocp-typerex.ocp.template

README

Requirements
============

* Linux (32-bit or 64-bit) or MacOS (tested with 10.6.8)
* OCaml >= 3.11.2
* Emacs (Tested with 23.2.1, does not work under X-Emacs, reported
  to work with Aquamacs but with performance issues)
* Gnu diff, present in PATH

Install
=======

1:  ./configure [options]

Usefull options (examples):
  --bindir=/opt/typerex
  --disable-version-check
      do not check OCaml version (allows, e.g., ocaml-3.12.1-rc1)
  --with-lispdir=~/.emacs.d
      default is a system-wide installation path
  --with-ocp-build=<command>
      default is 'ocp-build' if found, `pwd`/boot/ocp-build.boot otherwise
  --disable-auto-complete
      default is to install Emacs auto-complete, unless found in lispdir
  --enable-cmt
      binary-annotate typerex sources (for typerex developpers)

2:  make
3:  sudo make install

Append (and/or customize) the contents of emacs.append to your ~/.emacs:

4:  cat emacs.append >>~/.emacs

Uninstall
=========

To remove installed binaries and libraries:

- sudo make uninstall
Something went wrong with that request. Please try again.