Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support docker-compose v3 #218

Closed
MichaelMackus opened this Issue Mar 9, 2017 · 9 comments

Comments

8 participants
@MichaelMackus
Copy link

MichaelMackus commented Mar 9, 2017

Has some nice features from v2 that would be nice to implement. Not to mention it seems to largely be becoming the new standard version.

Just a thought since its a little frustrating having to convert my v3 files to the v2 format (which is mostly just a version number change away, along with some network frustrations).

@yinshiua

This comment has been minimized.

Copy link
Contributor

yinshiua commented Mar 10, 2017

Thanks for the request.

libcompose has an open issue for this docker/libcompose#421

@ingo

This comment has been minimized.

Copy link

ingo commented Oct 10, 2017

It doesn't seem like libcompose is moving quickly on this. The suggestion in the linked ticket was for people to use https://github.com/aanand/compose-file for v3 support. Thoughts?

@lechen26

This comment has been minimized.

Copy link

lechen26 commented Nov 4, 2017

any progress on the support of V3?
as ingo asked, is there any attempt to use https://github.com/aanand/compose-file instead of libcompose?

secrets cannot be used as its V3 related :\

@barbarosalp

This comment has been minimized.

Copy link

barbarosalp commented Dec 14, 2017

Any progress about version: "3" support?

@SoManyHs

This comment has been minimized.

Copy link
Contributor

SoManyHs commented May 2, 2018

We are actively working on supporting composeV3. You can follow changes in the compose3 branch.

In the meantime, @MichaelMackus it appears docker compose has introduced a --compatibility flag to convert V3 files to V2 (docker/compose#5684).

We would actually be interested in what specific features of v3 you are most interested in seeing integrated for your ECS tasks/services, as several of the new fields in v3 are specific to docker swarm only.

Any feedback would be greatly appreciated!
/c @ingo @lechen26 @barbarosalp

@allisaurus

This comment has been minimized.

Copy link
Contributor

allisaurus commented May 16, 2018

Adding on to @SoManyHs 's comment - we have a proposal up re: how we intend to handle container-level resources for Compose 3 (since v3 moves them to the swarm-specific deploy field). We welcome any comments/thoughts : #505

@allisaurus

This comment has been minimized.

Copy link
Contributor

allisaurus commented Jun 5, 2018

Compose 3 is supported as of release 1.6.0:
https://github.com/aws/amazon-ecs-cli/releases/tag/v1.6.0

Closing.

@allisaurus allisaurus closed this Jun 5, 2018

@FernandoMiguel

This comment has been minimized.

Copy link

FernandoMiguel commented Jul 18, 2018

which v3 is this?
3.0?

@SoManyHs

This comment has been minimized.

Copy link
Contributor

SoManyHs commented Jul 18, 2018

Hi @FernandoMiguel,
Yes, 3.0. We currently only support the x.0 major versions of docker compose.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.