Fix nokogiri dependency: demand ~> 1.5.10 instead of < 1.6.0 #361

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
3 participants

The previous nokogiri dependency (< 1.6.0) gave issues in our projects in combination with capybara, possibly due to a dependency resolving bug in Bundler. This has been mentioned in #273, bundler/bundler#2122, and bundler/bundler#2593.

This PR demands version ~> 1.5.10, which is effectively the same as demanding anything < 1.6.0, but after applying this PR our projects can bundle update normally with capybara and aws-sdk in the Gemfile.

Member

awood45 commented Sep 16, 2013

We have managed to reproduce the issue - using your PR change can resolve a particular bundler issue when using our SDK.

We're a bit concerned with forcing all of our users into what is essentially a lock into Nokogiri 1.5.10. Our old dependency was 1.4 or greater, so we may have users still on 1.4 who would be force-upgraded by this change. There have been known issues with specific versions of Nokogiri, so some customers may be broken by a forced upgrade. We are discussing these risks, and alternatives such as a ~> 1.5.0 dependency. Watch this space.

lsegal closed this in 0dff470 Sep 17, 2013

Contributor

lsegal commented Sep 17, 2013

I think the above commit satisfies all of our concerns in addition to making Bundler work correctly under these version conflict scenarios.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment