Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

docs build needs environment installation (graphviz error) #123

Open
aaronmarkham opened this issue Dec 6, 2019 · 1 comment
Open

docs build needs environment installation (graphviz error) #123

aaronmarkham opened this issue Dec 6, 2019 · 1 comment
Labels

Comments

@aaronmarkham
Copy link

@aaronmarkham aaronmarkham commented Dec 6, 2019

I tried building the docs, but was met with a graphviz error. Typically this means I can spend a few hours pecking away at the dependencies until I get stable build... or someone that has it working can export their environment, and publish an environment.yml that we can use with the build instructions.
I was going off of the d2l book since that's a dep here, but their environment.yml seems incompatible since I must work with Python 3.7 due to the MXNet pip wheel for Mac, and the environment doesn't mention graphviz. Which, by the way, I recommend not using at all because of issues I ran up against trying to get some tutorials working on Windows. Graphviz seems to have dropped caring about Windows. Separate issues, but if we can maybe keep things to matplotlib, we might have an easier time making things cross-platform and keeping the dependencies manageable.

@zhanghang1989

This comment has been minimized.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.