Error "Symbol not found: _EVP_DigestFinal_ex" #22

Closed
marc-fan opened this Issue Mar 22, 2012 · 4 comments

Comments

Projects
None yet
3 participants

Hi,

I try to compile the new version of pybloomfiltermmap. All seems to work when I launch "python setup.py install", but when I try to import the module, it returns the following error:

MacBook-Pro:axiak-pybloomfiltermmap-70a85e6 root# python
ActivePython 2.6.7.20 (ActiveState Software Inc.) based on
Python 2.6.7 (r267:88850, Jun 27 2011, 14:10:26)
[GCC 4.2.1 (Apple Inc. build 5664)] on darwin
Type "help", "copyright", "credits" or "license" for more information.

import pybloomfilter
Traceback (most recent call last):
File "", line 1, in
ImportError: dlopen(/var/root/.local/lib/python2.6/site-packages/pybloomfiltermmap-0.3.4-py2.6-macosx-10.5-intel.egg/pybloomfilter.so, 2): Symbol not found: _EVP_DigestFinal_ex
Referenced from: /var/root/.local/lib/python2.6/site-packages/pybloomfiltermmap-0.3.4-py2.6-macosx-10.5-intel.egg/pybloomfilter.so
Expected in: dynamic lookup

I verify if _EVP_DigestFinal_ex exists in my system:

MacBook-Pro:axiak-pybloomfiltermmap-70a85e6 root# nm -arch x86_64 /usr/lib/libcrypto.dylib | grep DigestFinal
0000000000056840 T _EVP_DigestFinal
00000000000567b0 T _EVP_DigestFinal_ex

MacBook-Pro:axiak-pybloomfiltermmap-70a85e6 root# nm -arch x86_64 /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk/usr/lib/libcrypto.dylib | grep DigestFinal
0000000000056840 T _EVP_DigestFinal
00000000000567b0 T _EVP_DigestFinal_ex

I can't undestand where I'm wrong!

Can you help me to solve this problem?
Thanks in advance!

Owner

axiak commented Sep 5, 2012

Did you ever fix this? I believe this is a missing dependency and I do not have a mac to test this on.

sjuxax commented Sep 25, 2012

I'm getting this on Arch Linux x86_64, Linux 3.5.4, with Python 2.7.

>>> import pybloomfilter
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: /usr/lib/python2.7/site-packages/pybloomfilter.so: undefined symbol: EVP_DigestFinal_ex

I also see EVP_DigestFinal_ex in my libcrypto.so:

$ nm /usr/lib/libcrypto.so | grep DigestFinal
0000000000114d70 T EVP_DigestFinal
0000000000114870 T EVP_DigestFinal_ex

This seems to prevent w3af_gui from starting on my machine.

axiak was assigned Sep 25, 2012

Owner

axiak commented Sep 25, 2012

Hey guys, Please try installing release 0.3.8. I have OS X now but was not able to reproduce this bug. I've included crypto as a library when compiling so that should help...

sjuxax commented Sep 25, 2012

Thanks axiak, that did fix my issue even though I am not on OS X but Arch Linux. :)

axiak closed this Mar 16, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment