Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Fix test/update-release-info/update-release-info.py to work in the ye…

…ar 2011
  • Loading branch information...
commit 4345b048fcbc94a032269c88a1058ab9171bf4d8 1 parent 503f1b9
William Deegan authored
View
2  QMTest/TestSCons.py
@@ -33,7 +33,7 @@
default_version = '2.1.0.alpha.yyyymmdd'
-copyright_years = '2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010'
+copyright_years = '2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011'
python_version_unsupported = (2, 3, 0)
python_version_deprecated = (2, 4, 0)
View
2  SConstruct
@@ -5,7 +5,7 @@
# When this gets changed, you must also change the copyright_years string
# in QMTest/TestSCons.py so the test scripts look for the right string.
-copyright_years = '2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010'
+copyright_years = '2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011'
# This gets inserted into the man pages to reflect the month of release.
month_year = 'MONTH YEAR'
View
10 test/update-release-info/update-release-info.py
@@ -69,13 +69,13 @@
"""version_tuple = (2, 0, 0, 'final', 0)
""",
# Index 5: bad release date
-"""release_date = (2010, 12)
+"""release_date = (2011, 12)
""",
# Index 6: release date (hhhh, mm, dd)
-"""release_date = (2010, 12, 21)
+"""release_date = (2011, 12, 21)
""",
# Index 7: release date (hhhh, mm, dd, hh, mm, ss)
-"""release_date = (2010, 12, 21, 12, 21, 12)
+"""release_date = (2011, 12, 21, 12, 21, 12)
""",
]
@@ -114,7 +114,7 @@ def combo_run(*args, **kw):
combo_strings[0] = combo_strings[1] + combo_strings[2] + combo_strings[3]
combo_fail(0, 5, stdout =
-"""ERROR: Invalid release date (2010, 12)
+"""ERROR: Invalid release date (2011, 12)
""")
def pave(path):
@@ -213,7 +213,7 @@ def updating_run(*args):
# should get Python floors from TestSCons module.
test.must_match(TestSCons, """
-copyright_years = '2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010'
+copyright_years = '2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011'
default_version = '2.0.0.alpha.yyyymmdd'
python_version_unsupported = (2, 3)
python_version_deprecated = (2, 4)
Please sign in to comment.
Something went wrong with that request. Please try again.