Skip to content
remove-use-strict plugin for gulp
JavaScript
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
test
.editorconfig
.gitattributes
.gitignore
.jshintrc
.travis.yml
LICENSE
README.md
index.js
package.json
yarn.lock

README.md

gulp-remove-use-strict

NPM version Build Status

remove-use-strict plugin for gulp

Usage

First, install gulp-remove-use-strict as a development dependency:

npm install --save-dev gulp-remove-use-strict

Then, add it to your gulpfile.js:

const removeUseStrict = require("gulp-remove-use-strict");

gulp.src("./src/*.js")
	.pipe(removeUseStrict())
	.pipe(gulp.dest("./dist"));

API

remove-use-strict([options])

options

Type: Object

options.force

Type: boolean
Default: false

Set to true to remove "use strict"; regardless of whether it appears as a directive prologue (see remove-use-strict for more details).

License

MIT License

You can’t perform that action at this time.