Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Cannot retrieve contributors at this time

48 lines (35 sloc) 1.59 kb
set -e
echo "Updates packages. Asks for your password."
sudo apt-get update -y
echo "Installs packages. Give your password when asked."
sudo apt-get install build-essential bison openssl libreadline6 libreadline6-dev curl git-core zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-0 libsqlite3-dev sqlite3 libxml2-dev libxslt-dev autoconf libc6-dev nodejs -y
echo "Installs ImageMagick for image processing"
sudo apt-get install imagemagick --fix-missing -y
echo "Installs RVM (Ruby Version Manager) for handling Ruby installation"
curl -L get.rvm.io | bash -s stable
source ~/.rvm/scripts/rvm
echo "Installs Ruby"
rvm install 1.9.3-p194
rvm use 1.9.3-p194 --default
gem install bundler --no-rdoc --no-ri
gem install rails --no-rdoc --no-ri
echo "Installs text editor"
sudo apt-get install gedit -y
echo -e "\n- - - - - -\n"
echo -e "Now we are going to print some information to check that everything is done:\n"
# brew in ubuntu?
# echo -n "Should be brew 0.8 or higher: brew "
# brew -v
echo -n "Should be sqlite 3.7.3 or higher: sqlite "
sqlite3 --version
echo -n "Should be rvm 1.6.32 or higher: "
rvm --version | sed '/^.*$/N;s/\n//g' | cut -c 1-10
echo -n "Should be ruby 1.9.3-p194: "
ruby -v | -d " " -f 2
echo -n "Should be Rails 3.2.2 or higher: "
rails -v
echo -e "\n- - - - - -\n"
echo "If the versions match, everything is installed correctly. If the versions
don't match or errors are shown, something went wrong with the automated process
and we will help you do the installation the manual way at the event.
Congrats!"
Jump to Line
Something went wrong with that request. Please try again.