New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

parseQuery() will be replaced with getOptions() in the next major version of loader-utils #392

Closed
Regaddi opened this Issue Feb 22, 2017 · 4 comments

Comments

Projects
None yet
4 participants
@Regaddi
Copy link

Regaddi commented Feb 22, 2017

I'm submitting a feature request

Webpack Version:
2.2.1

Babel Core Version:
6.5.2

Babel Loader Version:
6.3.2

Please tell us about your environment:
OSX 10.11.6

@existentialism

This comment has been minimized.

Copy link
Member

existentialism commented Feb 23, 2017

@Regaddi see #391

@danez

This comment has been minimized.

Copy link
Member

danez commented Mar 6, 2017

The deprecation warning is now fixed in v7.0.0

@damianobarbati

This comment has been minimized.

Copy link

damianobarbati commented May 10, 2017

@danez I still get the warning with "babel-loader": "v7.0.0-alpha.2".
Are you sure this is closed?

(node:51116) DeprecationWarning: loaderUtils.parseQuery() received a non-string value which can be problematic, see https://github.com/webpack/loader-utils/issues/56
parseQuery() will be replaced with getOptions() in the next major version of loader-utils.
    at Object.parseQuery (/Users/damiano/Desktop/quant01/node_modules/loader-utils/index.js:78:3)
    at Object.module.exports (/Users/damiano/Desktop/quant01/node_modules/file-loader/index.js:11:26)
    at Object.module.exports (/Users/damiano/Desktop/quant01/node_modules/url-loader/index.js:19:21)
    at LOADER_EXECUTION (/Users/damiano/Desktop/quant01/node_modules/loader-runner/lib/LoaderRunner.js:119:14)
    at runSyncOrAsync (/Users/damiano/Desktop/quant01/node_modules/loader-runner/lib/LoaderRunner.js:120:4)
    at iterateNormalLoaders (/Users/damiano/Desktop/quant01/node_modules/loader-runner/lib/LoaderRunner.js:229:2)
    at /Users/damiano/Desktop/quant01/node_modules/loader-runner/lib/LoaderRunner.js:202:4
    at /Users/damiano/Desktop/quant01/node_modules/enhanced-resolve/lib/CachedInputFileSystem.js:62:14
    at _combinedTickCallback (internal/process/next_tick.js:73:7)
    at process._tickCallback (internal/process/next_tick.js:104:9)
@danez

This comment has been minimized.

Copy link
Member

danez commented May 10, 2017

Look at the stack-trace, the warning you are seeing is coming from the file-loader or url-loader.

Btw you can also use the final 7.0.0 version now.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment