New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bump loader-utils and use getOptions #391

Merged
merged 1 commit into from Mar 4, 2017

Conversation

Projects
None yet
@existentialism
Copy link
Member

existentialism commented Feb 22, 2017

Fixes warning:

DeprecationWarning: loaderUtils.parseQuery() received a non-string value which can be problematic, see https://github.com/webpack/loader-utils/issues/56
parseQuery() will be replaced with getOptions() in the next major version of loader-utils.

Ref: webpack/loader-utils#56

@danez danez added this to the 7.0.0 milestone Feb 22, 2017

@danez

This comment has been minimized.

Copy link
Member

danez commented Feb 22, 2017

This breaks as the new loader-utils version drops support for node < 4

@danez danez changed the base branch from master to 7.0 Feb 22, 2017

@existentialism existentialism force-pushed the existentialism:bump-loader-utils branch from 75124ac to 77e63e6 Feb 22, 2017

@codecov

This comment has been minimized.

Copy link

codecov bot commented Feb 22, 2017

Codecov Report

Merging #391 into 7.0 will not change coverage.
The diff coverage is 100%.

@@           Coverage Diff           @@
##              7.0     #391   +/-   ##
=======================================
  Coverage   81.87%   81.87%           
=======================================
  Files           6        6           
  Lines         160      160           
  Branches       35       35           
=======================================
  Hits          131      131           
  Misses         13       13           
  Partials       16       16
Impacted Files Coverage Δ
src/index.js 82.85% <100%> (ø)

Continue to review full report at Codecov.

Legend - Click here to learn more
Δ = absolute <relative> (impact), ø = not affected, ? = missing data
Powered by Codecov. Last update a483384...77e63e6. Read the comment docs.

@Timer

This comment has been minimized.

Copy link
Contributor

Timer commented Feb 23, 2017

Considering that Node 4 is the oldest supported version of Node (0.10 and 0.12 being dead), one could argue it's not a breaking change.

@kaumac

This comment has been minimized.

Copy link

kaumac commented Feb 23, 2017

+1
this will hopefully fix #392

@gaearon

This comment has been minimized.

Copy link
Member

gaearon commented Feb 23, 2017

Can we release babel-loader@7 without waiting for Babel 7? Doesn't seem like they have to track each other.

@Nilegfx

This comment has been minimized.

Copy link

Nilegfx commented Feb 23, 2017

+1

@d3viant0ne

This comment has been minimized.

Copy link
Member

d3viant0ne commented Feb 24, 2017

@danez - Nothing related to Webpack 2.x supports node < 4. Agree with @Timer, I wouldn't consider this breaking as support for .10 / .12 was never there to begin with as support was dropped when NodeJS officially dropped their support of these versions.

Webpack will continue to drop support for versions as NodeJS does

This has been handled as a patch version for all loaders requiring the same change across the webpack-contrib org.

@d3viant0ne d3viant0ne referenced this pull request Feb 25, 2017

Closed

fix deprecated warning #395

2 of 9 tasks complete

@mojoaxel mojoaxel referenced this pull request Feb 25, 2017

Closed

update webpack and babel #2694

@hassox

This comment has been minimized.

Copy link

hassox commented Feb 27, 2017

I've been trying to get a new project up and this issue is so far very difficult to solve. This plugin is now at odds with most other loaders and loaderUtils does not support parseQuery anymore :( I'd love to see this (or something similar) get merged in soon :D

@mrtnbroder

This comment has been minimized.

Copy link

mrtnbroder commented Mar 2, 2017

Please release this asap, it's causing issues on our app.

@hiroppy hiroppy referenced this pull request Mar 2, 2017

Closed

fix deprecation warning #397

3 of 11 tasks complete
@danez

danez approved these changes Mar 4, 2017

@danez danez merged commit cc8b341 into babel:7.0 Mar 4, 2017

4 checks passed

codecov/patch 100% of diff hit (target 81.87%)
Details
codecov/project 81.87% (+0%) compared to a483384
Details
continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details

@existentialism existentialism deleted the existentialism:bump-loader-utils branch Mar 4, 2017

@blade254353074

This comment has been minimized.

Copy link

blade254353074 commented Mar 4, 2017

...We are waiting for this release

@danez

This comment has been minimized.

Copy link
Member

danez commented Mar 6, 2017

The deprecation warning is now fixed in v7.0.0-alpha.2

@mgol

This comment has been minimized.

Copy link

mgol commented Mar 13, 2017

@danez loader-utils is still tested in Node 4: https://github.com/webpack/loader-utils/blob/master/.travis.yml so it seems they should support it?

@danez

This comment has been minimized.

Copy link
Member

danez commented Mar 13, 2017

but not for node <4

@mgol

This comment has been minimized.

Copy link

mgol commented Mar 13, 2017

Ah, sorry, I read it incorrectly.

@tajo tajo referenced this pull request Mar 14, 2017

Merged

Modernize cf-ui #93

@corysimmons

This comment has been minimized.

Copy link

corysimmons commented Apr 14, 2017

Been through a couple walls of text. Using Node 7.4.0 with latest webpack and babel-loader. Still getting this error. Can someone summarize what's wrong and what needs to be done?

@Timer

This comment has been minimized.

Copy link
Contributor

Timer commented Apr 14, 2017

@corysimmons if you're using latest of babel-loader, that's your problem. You need to be on next.

If you are on next (v7), go ahead and run node with the --trace-deprecation flag to figure out exactly where the deprecation is coming from.

@corysimmons

This comment has been minimized.

Copy link

corysimmons commented Apr 14, 2017

yarn add -D babel-loader@next?

@Timer

This comment has been minimized.

Copy link
Contributor

Timer commented Apr 14, 2017

Yup, if you want to be more explicit @7.0.0-beta.1

@corysimmons

This comment has been minimized.

Copy link

corysimmons commented Apr 14, 2017

Thanks, works. 👍

@Vanuan

This comment has been minimized.

Copy link

Vanuan commented Apr 27, 2017

Does babel-loader@next work with babel-core 6?

@danez

This comment has been minimized.

Copy link
Member

danez commented Apr 27, 2017

@Vanuan Yes babel-loader does work with babel-core 6.x

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment