Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Downgrade semver for compatibility with Node 6 #10991

Merged
merged 1 commit into from Jan 12, 2020

Conversation

@nicolo-ribaudo
Copy link
Member

nicolo-ribaudo commented Jan 12, 2020

Q                       A
Fixed Issues? Fixes #10990
Patch: Bug Fix? Yes
Major: Breaking Change?
Minor: New Feature?
Tests Added + Pass? Yes
Documentation PR Link
Any Dependency Changes?
License MIT
@nicolo-ribaudo nicolo-ribaudo merged commit 2766837 into babel:master Jan 12, 2020
4 of 5 checks passed
4 of 5 checks passed
build (13.x)
Details
test262 Workflow: test262
Details
Travis CI - Pull Request Build Passed
Details
build-standalone Workflow: build-standalone
Details
e2e Workflow: e2e
Details
@nicolo-ribaudo nicolo-ribaudo deleted the nicolo-ribaudo:semver-downgrade branch Jan 12, 2020
@ljharb

This comment has been minimized.

Copy link
Member

ljharb commented Jan 12, 2020

@nicolo-ribaudo semver v6 also works down to node 0.8; i think that's the lowest you really need to go (and compared to v5, has better handling of prereleases)

@zloirock

This comment has been minimized.

Copy link
Member

zloirock commented Jan 12, 2020

Pinned semver@7.0 works fine with Node 6 and will be deduplicated with core-js-compat.

@nicolo-ribaudo

This comment has been minimized.

Copy link
Member Author

nicolo-ribaudo commented Jan 12, 2020

I used v5 because we are already using it in other Babel packages.
We can surely upgrade to a higher version now (or wait for Babel 8 soon and use ^7.0.0`), but I wanted to release a quick patch with a lower risk of breaking other things.

@eilon-shai

This comment has been minimized.

Copy link

eilon-shai commented Jan 12, 2020

when this version will be published?

@nicolo-ribaudo

This comment has been minimized.

Copy link
Member Author

nicolo-ribaudo commented Jan 12, 2020

It has already been published a few minutes after this PR has been merged. Only the updated packages have been released.

@eilon-shai

This comment has been minimized.

Copy link

eilon-shai commented Jan 13, 2020

our build is failing (node 6), and I think it relates to this fix, getting
npm ERR! typeerror Error: Missing required argument #1
it fail on babel installation, for example:
npm i @babel/code-frame@7.8.0
but when trying @babel/code-frame@7.8.1 it says that this version does not exists
(one of the original dependencies that is failing is jest-util@23.4.0, it for example use the @babel/code-frame@7.8.0)

@ljharb

This comment has been minimized.

Copy link
Member

ljharb commented Jan 13, 2020

That's an npm bug on windows, i believe (possibly a new, registry-caused one)

@eilon-shai

This comment has been minimized.

Copy link

eilon-shai commented Jan 13, 2020

this is happening both on jenkins (linux) and reproduced locally (mac os)
node 6.1.0 npm 3.8.6
npm i @babel/highlight@7.8.0 and others fail

@nicolo-ribaudo

This comment has been minimized.

Copy link
Member Author

nicolo-ribaudo commented Jan 13, 2020

They have been published: https://www.npmjs.com/package/@babel/highlight
The npm registry is buggy and regularly has this problem; please report it to them.

@babel/code-frame@7.8.1 has not been published because there wasn't any change to that package after 7.8.0.

@eilon-shai

This comment has been minimized.

Copy link

eilon-shai commented Jan 13, 2020

ok, thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

4 participants
You can’t perform that action at this time.