Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Don't force chokidar@2 to be downloaded from registry.npmjs.org #12182

Merged
merged 1 commit into from Oct 15, 2020

Conversation

@nicolo-ribaudo
Copy link
Member

@nicolo-ribaudo nicolo-ribaudo commented Oct 15, 2020

Q                       A
Fixed Issues? Fixes #12181
Patch: Bug Fix? Yes
Major: Breaking Change?
Minor: New Feature?
Tests Added + Pass? Yes
Documentation PR Link
Any Dependency Changes? https://github.com/nicolo-ribaudo/chokidar-2
License MIT

@nicolo-ribaudo nicolo-ribaudo added this to the v7.12.1 milestone Oct 15, 2020
@nicolo-ribaudo nicolo-ribaudo requested a review from JLHwung Oct 15, 2020
@babel-bot
Copy link
Collaborator

@babel-bot babel-bot commented Oct 15, 2020

Build successful! You can test your changes in the REPL here: https://babeljs.io/repl/build/30191/

@codesandbox
Copy link

@codesandbox codesandbox bot commented Oct 15, 2020

This pull request is automatically built and testable in CodeSandbox.

To see build info of the built libraries, click here or the icon next to each commit SHA.

Latest deployment of this branch, based on commit d81a3da:

Sandbox Source
babel-repl-custom-plugin Configuration
babel-plugin-multi-config Configuration
@nicolo-ribaudo nicolo-ribaudo force-pushed the nicolo-ribaudo:chokidar-2 branch from dbdd78d to d81a3da Oct 15, 2020
@nicolo-ribaudo nicolo-ribaudo merged commit b877726 into babel:main Oct 15, 2020
15 of 16 checks passed
15 of 16 checks passed
Prepare Cache
Details
Test on Node.js Latest
Details
Build Babel Artifacts
Details
Test on Node.js (13)
Details
Test on Node.js (12)
Details
Test on Node.js (10)
Details
Test on Node.js (8)
Details
Test on Node.js (6)
Details
test262-pr Workflow: test262-pr
Details
Gitpod Open an online workspace in Gitpod
Details
Travis CI - Pull Request Build Passed
Details
babel/repl REPL preview is available
Details
build-standalone Workflow: build-standalone
Details
ci/codesandbox Building packages succeeded.
Details
codecov/project 91.81% (target 90.00%)
Details
e2e Workflow: e2e
Details
@nicolo-ribaudo nicolo-ribaudo deleted the nicolo-ribaudo:chokidar-2 branch Oct 15, 2020
@nstepien
Copy link
Contributor

@nstepien nstepien commented Oct 15, 2020

I think the following could have worked as well:

    "chokidarAt2": "npm:chokidar@2.1.8"
@nicolo-ribaudo
Copy link
Member Author

@nicolo-ribaudo nicolo-ribaudo commented Oct 15, 2020

I think that it only works with yarn (https://docs.npmjs.com/files/package.json#dependencies does not mention it).

@nstepien
Copy link
Contributor

@nstepien nstepien commented Oct 15, 2020

Just did

npm i -D chokidarAt2@npm:chokidar@2.1.8

and it worked fine. I'm on npm 6.14.8.

And for extra confirmation, the package-lock.json ends up like this:

    "chokidarAt2": {
      "version": "npm:chokidar@2.1.8",
      "resolved": "https://registry.npmjs.org/chokidar/-/chokidar-2.1.8.tgz",
      "integrity": "sha512-ZmZUazfOzf0Nve7duiCKD23PFSCs4JPoYyccjUFF3aQkQadqBhfzhjkwBH2mNOG9cTBwhamM37EIsIkZw3nRgg==",
      "dev": true,
      "requires": {
        "anymatch": "^2.0.0",
        "async-each": "^1.0.1",
        "braces": "^2.3.2",
        "fsevents": "^1.2.7",
        "glob-parent": "^3.1.0",
        "inherits": "^2.0.3",
        "is-binary-path": "^1.0.0",
        "is-glob": "^4.0.0",
        "normalize-path": "^3.0.0",
        "path-is-absolute": "^1.0.0",
        "readdirp": "^2.2.1",
        "upath": "^1.1.1"
      },
      "dependencies": {
        ...
@JLHwung
Copy link
Contributor

@JLHwung JLHwung commented Oct 15, 2020

@nstepien The npm: protocol, ironically, is not documented on npm docs: https://docs.npmjs.com/files/package.json#dependencies Can you verify that npm:version-range works for Node.js 6 (Npm 3)?

@nstepien
Copy link
Contributor

@nstepien nstepien commented Oct 16, 2020

It doesn't work with npm 3 unfortunately:

> npx npm@^3 i -D chokidarAt2@npm:chokidar@2.1.8
npx: installed 266 in 8.811s
npm ERR! Windows_NT 10.0.19041
npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\xxx\\AppData\\Roaming\\npm-cache\\_npx\\11568\\node_modules\\npm\\bin\\npm-cli.js" "i" "-D" "chokidarAt2@npm:chokidar@2.1.8"npm ERR! node v6.17.1
npm ERR! npm  v3.10.10

npm ERR! Unsupported URL Type: npm:chokidar@2.1.8
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

4 participants
You can’t perform that action at this time.