New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update minimum version of babel-plugin-ember-modules-api-polyfill. #177

Merged
merged 1 commit into from Aug 15, 2017

Conversation

Projects
None yet
2 participants
@rwjblue
Copy link
Member

rwjblue commented Aug 15, 2017

This now provides import Ember from 'ember' (and therefore removes the requirement of addons and/or apps to have ember-cli-shims installed).

Update minimum version of babel-plugin-ember-modules-api-polyfill.
This now provides `import Ember from 'ember'` (and therefore removes
the requirement of addons and/or apps to have `ember-cli-shims`
installed).

diff --git a/package.json b/package.json
index 5c0b3c7..344026d 100644
--- a/package.json
+++ b/package.json
@@ -36,7 +36,7 @@
   "dependencies": {
     "amd-name-resolver": "0.0.7",
     "babel-plugin-debug-macros": "^0.1.11",
-    "babel-plugin-ember-modules-api-polyfill": "^1.4.1",
+    "babel-plugin-ember-modules-api-polyfill": "^1.5.0",
     "babel-plugin-transform-es2015-modules-amd": "^6.24.0",
     "babel-polyfill": "^6.16.0",
     "babel-preset-env": "^1.5.1",
diff --git a/yarn.lock b/yarn.lock
index aba0158..23b3ced 100644
--- a/yarn.lock
+++ b/yarn.lock
@@ -140,6 +140,12 @@ amd-name-resolver@0.0.6:
   dependencies:
     ensure-posix-path "^1.0.1"

+amd-name-resolver@0.0.7:
+  version "0.0.7"
+  resolved "https://registry.yarnpkg.com/amd-name-resolver/-/amd-name-resolver-0.0.7.tgz#814301adfe8a2f109f6e84d5e935196efb669615"
+  dependencies:
+    ensure-posix-path "^1.0.1"
+
 amdefine@>=0.0.4:
   version "1.0.1"
   resolved "https://registry.yarnpkg.com/amdefine/-/amdefine-1.0.1.tgz#4a5282ac164729e93619bcfd3ad151f817ce91f5"
@@ -496,6 +502,12 @@ babel-plugin-ember-modules-api-polyfill@^1.4.1:
   dependencies:
     ember-rfc176-data "^0.2.0"

+babel-plugin-ember-modules-api-polyfill@^1.5.0:
+  version "1.5.0"
+  resolved "https://registry.yarnpkg.com/babel-plugin-ember-modules-api-polyfill/-/babel-plugin-ember-modules-api-polyfill-1.5.0.tgz#5ab880597d44118ee56c21d143f75f245efd4e95"
+  dependencies:
+    ember-rfc176-data "^0.2.0"
+
 babel-plugin-htmlbars-inline-precompile@^0.2.3:
   version "0.2.3"
   resolved "https://registry.yarnpkg.com/babel-plugin-htmlbars-inline-precompile/-/babel-plugin-htmlbars-inline-precompile-0.2.3.tgz#cd365e278af409bfa6be7704c4354beee742446b"

@rwjblue rwjblue merged commit fa5583d into babel:master Aug 15, 2017

2 checks passed

continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details

@rwjblue rwjblue deleted the rwjblue:update-modules-polyfill branch Aug 15, 2017

@Turbo87 Turbo87 added the bug label Aug 31, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment