New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

flatpak address is not working #30

Open
millerthegorilla opened this Issue Nov 11, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@millerthegorilla

millerthegorilla commented Nov 11, 2018

Hi, I'd like to install this for fedora, but the flatpak address at the website is not working, and I can't find nutty listed on flathub. I tried the open suse 64bit rpm but it requires libnotify-tools, a package not available on fedora (which might be libnotify or libnotify-devel).
If there is not flatpak/snap package then I can always use the source code I guess. Any ideas on dependency packages for fedora?

Many thanks

@babluboy

This comment has been minimized.

Owner

babluboy commented Nov 11, 2018

@millerthegorilla Thanks for your interest in Nutty.

I will have to remove the flatpak link on the website as the flatpak devs said it is not possible to use cron with nutty inside flatpak container. Until I have some sort of daemon the flatpak has to wait.

I don’t have fedora, so it will be great if you can help me find the library equivalent names of the packages so that I can add it to the website for fedora users.

I’m in the process of getting nutty set up with ninja instead of cmake. If you want to build nutty now then best to get the source code from the last release (link below) and build from source using cmake.

https://github.com/babluboy/nutty/releases/tag/1.1.0

I should be able to check and fix the ninja build shortly. Let me know how it goes and we can use this issue to have build instructions for Fedora.

@babluboy

This comment has been minimized.

Owner

babluboy commented Nov 11, 2018

@millerthegorilla
Libnotify-tools is required for the libnotify package and if you are building from source then the dev package is required.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment