New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Package 'git' is broken after update #259

Closed
kgizdov opened this Issue Mar 24, 2015 · 4 comments

Comments

Projects
None yet
4 participants
@kgizdov

kgizdov commented Mar 24, 2015

Hi,

I installed 'babun' today and tried to update 'git', as the included version is very old (1.7.x). Firstly, it did not update through 'pact' -> 'git already installed'. So I tried as suggested in the issues here to remove and reinstall,

After 'pact remove git' and 'pact install git', it installed fine (I updated the MD5 to SHA512 fix in pact). However, now 'git' is not a valid command in babun. 'git' returns nothing regardless of operands and other packages return that 'git' is not installed.

Moreover, there is no way of returning 'git' to the older version at all. The only option is complete reinstallation of 'babun' itself. This is very disappointing as I cannot rely on an old version of 'git' got my projects and I also cannot use the new version...

Is there going to be a new release that fixes this soon? Or at least if someone can build from updated source as I do not have a machine configured for building cygwin currently.

Thanks.

@tombujok

This comment has been minimized.

Show comment
Hide comment
@tombujok

tombujok Mar 25, 2015

Contributor

We've been working on it for the last two weeks. The release will follow soon, for now reinstall babun to make git working again.

Contributor

tombujok commented Mar 25, 2015

We've been working on it for the last two weeks. The release will follow soon, for now reinstall babun to make git working again.

@tombujok

This comment has been minimized.

Show comment
Hide comment
@tombujok

tombujok Mar 30, 2015

Contributor

Fixed in 1.1.0.
Release status: #266

Contributor

tombujok commented Mar 30, 2015

Fixed in 1.1.0.
Release status: #266

@tombujok tombujok closed this Mar 30, 2015

@discernment

This comment has been minimized.

Show comment
Hide comment
@discernment

discernment Jul 20, 2017

I just had this happen to me. I was running babun 1.2.0. I did a pact update git and said that it was removing git. Now I get a 127 error code whenever running git. It's totally gone! Babun is worthless to me if git is not available and upgradeable.

discernment commented Jul 20, 2017

I just had this happen to me. I was running babun 1.2.0. I did a pact update git and said that it was removing git. Now I get a 127 error code whenever running git. It's totally gone! Babun is worthless to me if git is not available and upgradeable.

@jcao219

This comment has been minimized.

Show comment
Hide comment
@jcao219

jcao219 Sep 7, 2017

@discernment Go to the .babun directory in your Users directory and execute update.bat as administrator . The problem will be fixed.

jcao219 commented Sep 7, 2017

@discernment Go to the .babun directory in your Users directory and execute update.bat as administrator . The problem will be fixed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment