Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

XML Sitemap Node Tests #28

Open
alexfinnarn opened this issue Dec 3, 2016 · 3 comments

Comments

@alexfinnarn
Copy link
Contributor

commented Dec 3, 2016

135 passes, 5 fails, 0 exceptions, and 26 debug messages

All failures in xmlsitemap_node.test

@alexfinnarn

This comment has been minimized.

Copy link
Contributor Author

commented Dec 5, 2016

The problem appears in the testCron() method when $types = xmlsitemap_get_link_type_enabled_bundles('node') doesn't return anything. The newly created nodes don't get processed and so the assertions fail. This seems like an issue with variables or the database, but not indicative of a major bug in the module.

@alexfinnarn

This comment has been minimized.

Copy link
Contributor Author

commented Jul 19, 2018

In #57, the code changed to not create sitemap links on node update but rather queue those for cron. the tests need to be updated to relfect that change.

@jenlampton

This comment has been minimized.

Copy link
Member

commented Jul 8, 2019

I'm seeing something similar in #88

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.