Permalink
Browse files

remove notifications, multiple rvm rubies from guard

  • Loading branch information...
1 parent 37287bb commit ce29112a63919d6088af24308cc20fc62b63bc59 Brian D. Burns committed Mar 6, 2013
Showing with 6 additions and 16 deletions.
  1. +3 −4 Gemfile
  2. +3 −12 Guardfile
View
@@ -21,10 +21,9 @@ group :development do
gem 'guard'
gem 'guard-rspec'
gem 'fuubar'
- gem 'rb-fsevent' # guard notifications for osx
- gem 'growl' # $ brew install growlnotify
- gem 'rb-inotify' # guard notifications for linux
- gem 'libnotify' # $ apt-get install ???
+
+ gem 'rb-fsevent', :require => false # Mac OS X
+ gem 'rb-inotify', :require => false # Linux
gem 'yard'
gem 'redcarpet'
View
@@ -1,20 +1,11 @@
# encoding: utf-8
-# To run the test suite against all 3 rubies: 1.9.3, 1.9.2, and 1.8.7, simply run the following command:
-#
-# $ guard start
-#
-# Be use you are using RVM and have Ruby 1.9.3, 1.9.2, 1.8.7 installed as well as all of Backup's gem
-# dependencies for each of these Ruby versions.
-#
-# Be sure to run `bundle install` against every Ruby version, as well as `gem install thor POpen4`
-
+ENV['GUARD_NOTIFY'] = 'false'
guard "rspec",
- :rvm => ["2.0.0", "1.9.3", "1.9.2", "1.8.7"],
:cli => "--color --format Fuubar",
- :notification => false,
:all_after_pass => false,
- :all_on_start => false do
+ :all_on_start => false,
+ :keep_failed => false do
watch("lib/backup.rb") { "spec" }
watch("spec/spec_helper.rb") { "spec" }

0 comments on commit ce29112

Please sign in to comment.