Update dependancies to more recent #334

Closed
wants to merge 2 commits into
from

Projects

None yet

8 participants

@garrensmith

I needed to update these to more recent version to work with Rails 3.2.6, all tests passing with ruby 1.9.3p194 Also now works with rails version

@inferiorhumanorgans

The net-ssh requirement is also unnecessarily restrictive. I'm using '~> 2.3' with no problems.

@garrensmith

If you want to use this branch and you using bundler, add the following to your Gemfile
gem 'backup', :git => 'https://github.com/garrensmith/backup.git'

@webmat
webmat commented Jul 21, 2012

+1. I've also loosened a few dependencies on my own fork and it seems to be working well.

I think using ~> with 3 decimals if probably overly pessimistic (fog ~> 1.1.0 only lets one upgrade within 1.1.x). I'd be comfortable with specifying wiggle room for the 2nd number, as in ~> 1.1 (which would work with 1.3).

@Antiarchitect

Better use backup outside of your Gemfile. I'm currently using it with special rvm gemset for backup purposes because backup depends on such fast-changing gems as mail, multi_json that change own versions with rails upgrade.

@swills
swills commented Jul 26, 2012

+1 Please release an updated version using these changes.

@franciscoj

+1 on this, would help us a lot.

@opsidao
opsidao commented Aug 29, 2012

+1 from me too, 3.2.6 was released in june and since then we're forced to use our own fork...

@catmando

Same problem here in spades. However my solution was to add the following to the config file.

module ::Backup
  class Dependency
    class << self
      alias default_all all
      def all
        default_hash = default_all
        default_hash["fog"][:version] = '~> 1.8.0'
        default_hash["mail"][:version] = '~> 2.5.0'
        return default_hash
      end
    end
  end
end
@ghost
ghost commented Feb 19, 2013

See #386

@ghost ghost closed this Feb 19, 2013
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment