Fix segfaults with Popen4 and Ruby 1.8.7 #369

Closed
wants to merge 1 commit into
from

Projects

None yet

2 participants

@joeyimbasciano

When using Ruby 1.8.7 with Popen4 ruby regularly segfaults.

This is a well-known work around for that issue.

I was able to easily reproduce this issue on:

  • Ubuntu 12.04 + ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]
  • Take a dump that lasts a couple minutes, GC will come around and segfault your face!

See:
http://tickets.opscode.com/browse/CHEF-2916
engineyard/engineyard#115

@tomash
tomash commented Nov 2, 2012

i'm generally +1 on this. any objections?

@ghost
ghost commented Jan 16, 2013

Done: 4f2f377
Thanks!

@ghost ghost closed this Jan 16, 2013
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment