Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

libgconf-2.so.4 missing on Ubuntu 18.02 Beta #2191

Closed
probonopd opened this issue Apr 10, 2018 · 10 comments

Comments

@probonopd
Copy link

commented Apr 10, 2018

On ubuntu-18.04-beta2-desktop-amd64.iso getting

me@host:~$ /isodevice/Applications/etcher-1.3.1-x86_64.AppImage 
3654
/tmp/.mount_OjZb9X/usr/bin/etcher-electron: error while loading shared libraries: libgconf-2.so.4: cannot open shared object file: No such file or directory
@probonopd

This comment has been minimized.

Copy link
Author

commented Apr 10, 2018

Error can be worked around by

sudo apt -y install libgconf2-4

Proper solution is to get rid of the dependency, or bundle it.

@lurch

This comment has been minimized.

Copy link
Contributor

commented Apr 10, 2018

Duplicate of #1305 ?

@probonopd

This comment has been minimized.

Copy link
Author

commented Apr 10, 2018

Oops, apparently yes, sorry. Closing here, Discussion should continue in #1305.

@probonopd probonopd closed this Apr 10, 2018

@Bes0n

This comment has been minimized.

Copy link

commented Mar 24, 2019

Finally made possible to run Atom on my Elementary OS by installing this dependency. Thanks

@Yogesh9900

This comment has been minimized.

Copy link

commented Mar 25, 2019

Just do this sudo apt -y install libgconf2-4

@jhonnyW

This comment has been minimized.

Copy link

commented May 1, 2019

on ubuntu 19.04
Package 'libgconf2-4' has no installation candidate

@lurch

This comment has been minimized.

Copy link
Contributor

commented May 1, 2019

@jhonnyW see #1305 (comment) about enabling the 'universe' repository.

@Quintanar777

This comment has been minimized.

Copy link

commented May 1, 2019

on ubuntu 19.04
Package 'libgconf2-4' has no installation candidate

apt-get install libgconf-2-4

@lurch

This comment has been minimized.

Copy link
Contributor

commented May 1, 2019

@Quintanar777 Oooh, that's interesting. Looks like in 16.04, 18.04 and 18.10 Ubuntu provide a libgconf2-4 dummy package (which presumably depends on the real libgconf-2-4 package), but from 19.04 onwards Ubuntu only provides a libgconf-2-4 package and not a libgconf2-4 package.

EDIT: Fortunately, my old comment I linked to above was already using the "real" libgconf-2-4 package name 😃

@prashantjeena

This comment has been minimized.

Copy link

commented Jun 10, 2019

Error can be worked around by

sudo apt -y install libgconf2-4

Proper solution is to get rid of the dependency, or bundle it

how to repair the same in windows?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
8 participants
You can’t perform that action at this time.