Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Sound stutters/cuts out or skips every 30 seconds (RTP and SBC error) #62

Open
Nibbos opened this issue Dec 4, 2019 · 35 comments
Open
Labels
bluetooth Everything about the bluetooth container bug Something isn't working

Comments

@Nibbos
Copy link

Nibbos commented Dec 4, 2019

Experiencing regular sound cutting off when using bluetooth project suggested here:
[https://www.balena.io/blog/turn-your-old-speakers-or-hi-fi-into-bluetooth-receivers-using-only-a-raspberry-pi/]
I added a new DEVICE CONFIGURATION variable, ‘RESIN_HOST_CONFIG_dtoverlay’ and set its value to ‘pi3-disable-wifi’ but this seems to have no effect - although I can no longer connect to the Pi 3 from the BalenaSound interface (because the wifi on my Pi 3 has been turned off, ironically) and so cannot change anything else now. Nor do I know how to turn wifi back on again since I can't PuTTY into it either...
Some discussion already here:https://forums.balena.io/t/balenasound-blueooth-audio-on-raspberry-pi-3-sound-skipping-dropping/40894/4
but I cannot connect via ethernet either. Device marked as 'Offline' by Balena web-interface.

Can anyone suggest a possible fix to this, please? I’m semi-competent with Pi but do need simple, clear instructions to guide me.
Without a fix this glitch is just too annoying to live with.
I would buy a dedicated bluetooth receiver for my stereo but I felt that re-purposing a Pi 3 would be more appropriate and allow me to stream via a DAC slound card that I am going to add to the Pi (if I can fix the sound issue).
Thanks in advance.
Nibbos

PS please don't ask for output files from the Pi since I am no longer able to communicate with it as a consequence of turning wifi off,

@AlexProgrammerDE
Copy link
Collaborator

AlexProgrammerDE commented Dec 11, 2019

@Nibbos I have a connection resolution for you. You can simply flash the image again. (The part with the micro sd card and BalenaEtcher) The PI will get on its own the project files back and then everything should work. But dont forget to delete the from you set var before doing everything.

@stebla27
Copy link

stebla27 commented Dec 14, 2019

My sound drops also on Raspi 4! In log you can see:
bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 9953 != 9952
14.12.19 15:57:17 (+0100) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 9956 != 9954
14.12.19 15:57:17 (+0100) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 9964 != 9957
14.12.19 15:57:17 (+0100) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 9967 != 9966
14.12.19 15:57:17 (+0100) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 9973 != 9972
14.12.19 15:57:17 (+0100) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 9977 != 9975
14.12.19 15:57:19 (+0100) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 10068 != 10067
14.12.19 15:57:19 (+0100) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 10071 != 10070
14.12.19 15:57:19 (+0100) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 10105 != 10103

Not really a stable connection and unusable in this state!

@AlexProgrammerDE
Copy link
Collaborator

AlexProgrammerDE commented Dec 14, 2019

This error of you @stebla27 is very similar to the one in #47 . You can try it with another balenaOS version or a bluetooth dongle.

@stebla27
Copy link

stebla27 commented Dec 14, 2019

This error of you @stebla27 is very similar to the one in #47 . You can try it with another balenaOS version or a bluetooth dongle.

I use balenaOS 2.41! I can't select another version in the balena backend!
Raspi 4 has bluetooth on board! Why should I use a Bluetooth dongle?

@AlexProgrammerDE
Copy link
Collaborator

AlexProgrammerDE commented Dec 14, 2019

@stebla27

  1. When you download the image can you (as far as i know) select the version,at the page of the wifi password and developement or factory option.
  2. In some cases the proximity or the build in bluetooth of your mobile causes trouble. Some people solved this type of error with a bluetooth dongle.

@javexed
Copy link

javexed commented Dec 16, 2019

I can confirm this issue is with the Raspberry Pi 3+ as well. Moving to direct streaming fixed the audio quality (not really a proper solution) as that bypasses the bluetooth radio and streams over the wifi connection.

@AlexProgrammerDE
Copy link
Collaborator

AlexProgrammerDE commented Dec 16, 2019

@javexed do you have logs from the dashboard?

@AlexProgrammerDE
Copy link
Collaborator

AlexProgrammerDE commented Dec 16, 2019

By the way here is a link to a issue in bluealsa with the same errors: Arkq/bluez-alsa#110

@javexed
Copy link

javexed commented Dec 16, 2019

Yes, looks similar to that issue, here are some of the logs:

08.12.19 08:05:24 (-0500) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 48438 != 48437
08.12.19 08:05:38 (-0500) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 49413 != 49410

@javexed
Copy link

javexed commented Dec 16, 2019

Other important note, balena diagnostics also show under voltage. Am looking for a better power supply to see if it is related to this issue.

@AlexProgrammerDE
Copy link
Collaborator

AlexProgrammerDE commented Dec 16, 2019

@javexed Good idea!

@Jordan-Adelson
Copy link

Jordan-Adelson commented Dec 21, 2019

Having the same issue myself. Bluetooth connection from a Huawai Mate 10 to RPI 3. Noted that some users suspected this was an iOS issue, likely not limited to iOS.

These are the two errors repeated in my logs.
21.12.19 22:35:35 (+1100) bluetooth-audio /usr/bin/bluealsa: SBC decoding error: No such process
21.12.19 22:35:35 (+1100) bluetooth-audio /usr/bin/bluealsa: Missing RTP packet: 27632 != 27630

Have tested moving the devices closer together and further apart, seems to have little impact on the errors until there is a considerable distance between them.

Is there any sort of buffer that can be turned on?

Have not tried turning wifi off yet noticing that many others have not seen any improvement.

Seems to defeat the purpose of the project a bit if having to get an additional Bluetooth dongle is the solution.

@perseus177
Copy link

perseus177 commented Jan 5, 2020

Sound cuts out or skips every 30 seconds
Same problem when I am using Samsung Galaxy S10+

No problem when I am using iPhone 6S

@tmigone
Copy link
Contributor

tmigone commented Jan 20, 2020

Hello,

Stuttering issues on the Raspberry Pi 3 are related to a known problem with the BT/WiFi chip. Both the chip manufacturer (Cypress) and the Raspberry Pi Foundation have acknowledged this but unfortunately it does not seem to be a high priority task for them (and I asume it's less likely to happen since the Pi 4 came out and does not have this problem).

The current "workaround" is to use a bluetooth usb dongle and disable the Pi's internal bluetooth, as long as the bluetooth dongle gets assigned the device name hci0 you should be fine (which in my experience is always, but let me know if it's not).

We realize having to buy a bluetooth adapter for a brand new Raspberry Pi is not an optimal solution so we've reached out to the foundation to see if there is anything we can do to help; however I don't anticipate a resolution to this problem anytime soon.

In case anyone is curious, here are the relevant GitHub issues:

For future reference, here is the typical log output you get when experiencing this issue:

20.01.20 18:14:30 (+0400)  bluetooth-audio  /usr/bin/bluealsa: SBC decoding error: No such process
20.01.20 18:14:30 (+0400)  bluetooth-audio  /usr/bin/bluealsa: Missing RTP packet: 7047 != 7034
20.01.20 18:14:32 (+0400)  bluetooth-audio  /usr/bin/bluealsa: SBC decoding error: No such process
20.01.20 18:14:35 (+0400)  bluetooth-audio  /usr/bin/bluealsa: SBC decoding error: No such file or directory
20.01.20 18:14:36 (+0400)  bluetooth-audio  /usr/bin/bluealsa: Missing RTP packet: 7433 != 7430
20.01.20 18:14:37 (+0400)  bluetooth-audio  /usr/bin/bluealsa: Missing RTP packet: 7536 != 7535

@tmigone tmigone added the bug Something isn't working label Jan 22, 2020
@damaev
Copy link

damaev commented Feb 18, 2020

Hi everybody,

I really spend a lot of time trying to figure out the reason for my stuttering audio (with wifi off) while a working solution for my issue has already been released years ago: reducing the baudrate to 460800. (I was always thinking about increasing it...) See original post here: raspberrypi/linux#2264 (comment)

What to do:
edit /usr/bin/btuart (loaded during boot by hciuart.service)
reduce the baud rate from 921600 to 460800 (in the only possible line)

Following additional information:

The rev 1.2 Pi3B lacks the flow control signals to the Bluetooth modem (we ran out of pins), but the rev 1.3 board drops the BT PCM interface and hooks up the flow control. I think what you are seeing is occasional data loss when the FIFOs overflow, something which is hard to avoid in all circumstances. You may be able to lessen the problem by reducing the baudrate on the modem - try editing /usr/bin/btuart, replacing the 921600 with 460800 and rebooting."

It seems the 3B+ has the same problem described here for the first revisions of the 3B.

Originally posted by @docgloucester in nicokaiser/rpi-audio-receiver#38 (comment)

@tmigone
Copy link
Contributor

tmigone commented Feb 19, 2020

hi @damaev , thanks for your contribution!

I just want to add that some time ago I tested the solution you propose and I had mixed results, it did make the stuttering less noticeable on one of my devices, but had no impact on another. If enough people report that it provides a noticeable benefit we definitely should consider patching it or at least mentioning it on the README.

@balena-ci
Copy link
Contributor

balena-ci commented Mar 3, 2020

[tmigone] This issue has attached support thread https://jel.ly.fish/#/24fa6e02-fed3-4795-985d-e852d76448ba

@balena-ci
Copy link
Contributor

balena-ci commented Mar 4, 2020

[nazrhom] This issue has attached support thread https://jel.ly.fish/#/04d90a91-8eaf-413f-b689-88417a993d40

@nazrhom
Copy link
Contributor

nazrhom commented Mar 4, 2020

Hey @tmigone @chrisys, a user in the support thread linked above mentioned they experienced similar issues after changing the BLUETOOTH_DEVICE_NAME env var, and were able to resolve the issues when deleting that.

@Daniol71
Copy link

Daniol71 commented Mar 4, 2020

Hi, been looking at this issue for a little while now and downgrading to balenaOS v2.38.0+rev1 fixed my bluetooth issues on the RPi3. Obviously a temporary fix but hopefully it helps someone identify what in the following updates broke bluetooth on the RPi3 (perhaps something that got added with RPi4 support). Hope it helps, original post https://forums.balena.io/t/balenasound-blueooth-audio-on-raspberry-pi-3-sound-skipping-dropping/40894/40?u=cdl

@MatthewCroughan
Copy link
Contributor

MatthewCroughan commented Mar 27, 2020

I concur and have had the same experience as Daniol71. Bluetooth performance is much better after reverting to balenaOS v2.38.0+rev1. Though sometimes packets still do drop in an annoying manner, I can't get through a single tune without being irked by it.

It can't be understated that balenaOS v2.38.0+rev1 is still much more usable, so something has definitely went wrong in later versions.

If a bluetooth adapter is required, and it seems like it is to get a baseline usable experience, that should be noted in the README.md of the repository.

Here's a typical log from dmesg when playing back music over Bluetooth:

[  344.033690] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.033769] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.033853] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.033940] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.034026] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.034113] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.034199] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.034352] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.034398] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.034486] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.034572] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.034659] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.034746] Bluetooth: hci0: Frame reassembly failed (-84)
[  344.034846] Bluetooth: hci0: Frame reassembly failed (-84)
[  376.771228] systemd-udevd[30]: seq 2173 '/devices/virtual/input/input1' killed
[  376.773983] systemd-udevd[30]: worker [94] terminated by signal 9 (Killed)
[  376.774023] systemd-udevd[30]: worker [94] failed while handling '/devices/virtual/input/input1'

@MatthewCroughan
Copy link
Contributor

MatthewCroughan commented Mar 27, 2020

Scratch that. It seems that it has randomly recovered, as if it has warmed up and is no longer dropping packets. Quite odd. The kernel log is not reporting any undervoltage via dmesg, which is the only thing I can think of that would cause it to be so strangely intermittent.

The power supply I'm using is an older model of this. Perhaps something fishy is going on with regards to power delivery and all these "smart charging" features. I'll try with an official PSU at some point and report back.

@MatthewCroughan
Copy link
Contributor

MatthewCroughan commented Mar 27, 2020

As things got better, they got worse, as can be expected from power issues. After some time there were consistent undervoltages reported via dmesg, as well as a lot of Frame reassembly failed (-84).

At the very top of the kernel log, at boot-time, there was a single undervoltage reported. This was not then reported continually until around 10-20 mins of usage. I should have saved the logs so this was evident, but did not do so.

I've swapped this PSU out for a Motorola 2A PSU, not in any way official or validated for the Pi. Next I'm going to try a Xioami 3A PSU, one that I got with my Xiaomi Mi 9 if there are issues.

@MatthewCroughan
Copy link
Contributor

MatthewCroughan commented Mar 27, 2020

Wow. I didn't expect to see such a difference between all these PSUs. I exposed each PSU to around 15 mins of testing using the same mobile device to stream audio via Bluetooth.

Aukey 3A with "Smart Charging":

  • Lots of frame reassembly failure
  • Undervoltage reported every now and then

Motorola 2A PSU:

  • Less frame reassembly failure
  • Bursts of reassembly failure every minute or so
  • No undervoltage was reported from the kernel at any stage

Motorola 3A PSU:

  • Frame reassembly failure only occurred at the moment of connection from the mobile device
  • No reassembly failure during usage, whatsoever
  • No undervoltage reported

The 3A PSU seems to be providing me with a pretty much flawless experience.

@AlexProgrammerDE
Copy link
Collaborator

AlexProgrammerDE commented Mar 27, 2020

@MatthewCroughan what Pi are you using?

@MatthewCroughan
Copy link
Contributor

MatthewCroughan commented Mar 27, 2020

After about 30 mins of playback, I just received a second burst of reassembly errors. Though this is not a problem, as I have lots of other equipment that has similar hickups and it is to be expected. It's performing better than my bluetooth earbuds for example

[  100.347229] systemd-udevd[29]: seq 1838 '/devices/virtual/input/input0' is taking a long time
[  220.355463] systemd-udevd[29]: seq 1838 '/devices/virtual/input/input0' killed
[  220.356826] systemd-udevd[29]: worker [99] terminated by signal 9 (Killed)
[  220.356859] systemd-udevd[29]: worker [99] failed while handling '/devices/virtual/input/input0'
[  253.528102] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.528875] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.528934] Bluetooth: hci0 ACL packet for unknown connection handle 608
[  253.528964] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.529077] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.529146] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.529241] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.529320] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.529406] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.529492] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.529579] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.529666] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.529752] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.529840] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.529925] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.530013] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.530100] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.530185] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.530271] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.530359] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.530446] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.530532] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.530617] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.530704] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.530791] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.530878] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.530966] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.531055] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.531145] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.531240] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.531325] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.531413] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.531496] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.531582] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.531671] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.531683] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.531755] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.531842] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.531928] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.533367] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.533450] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.533536] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.533619] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.533705] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.533792] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.533879] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.533966] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.534052] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.534139] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.534224] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.534312] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.534398] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.534487] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.534573] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.534659] Bluetooth: hci0: Frame reassembly failed (-84)
[  253.534747] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.902267] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.902328] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.902492] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.902527] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.902610] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.903028] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.903147] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.903239] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.903336] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.903437] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.903536] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.903649] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.903667] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.903769] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.903852] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.903961] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.904064] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.904102] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.904199] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.904314] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.904412] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.904474] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.904641] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.904743] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.904835] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.904932] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.905035] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.905115] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.905198] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.905284] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.905372] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.905458] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.905544] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.905630] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.905717] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.905805] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.905893] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.905978] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.906064] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.906150] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.906236] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.906324] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.906410] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.906497] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.906586] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.906670] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.906757] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.906844] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.906931] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907017] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907104] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907190] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907277] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907387] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907466] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907543] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907625] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907711] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907797] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907884] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907896] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.907970] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.908056] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.908143] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.908230] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.908316] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.908403] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.922299] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.922305] Bluetooth: hci0 SCO packet for unknown connection handle 43084
[ 1329.922366] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.922521] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.923326] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.923395] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.923978] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.924062] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.924146] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.924234] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.924319] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.924405] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.924490] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.924579] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.924663] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.924676] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.924749] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.924835] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.924922] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.925009] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.925095] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.925182] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.925275] Bluetooth: hci0: Frame reassembly failed (-90)
[ 1329.925355] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.925442] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.925529] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.925616] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.925702] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.926717] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.926761] Bluetooth: hci0: Frame reassembly failed (-84)
[ 1329.927171] Bluetooth: hci0: Frame reassembly failed (-84)

Interestingly, the udevd errors I've mentioned in #117 have also not yet ocurred when using the 3A PSU.

@MatthewCroughan
Copy link
Contributor

MatthewCroughan commented Mar 27, 2020

@AlexProgrammerDE I'm using a Pi3 Model B V1.2

@chrisys
Copy link
Member

chrisys commented Apr 1, 2020

@MatthewCroughan that's some awesome investigative work! I too had no idea that the PSU was playing that much of a part here

@AlexProgrammerDE AlexProgrammerDE added the bluetooth Everything about the bluetooth container label Apr 1, 2020
@AlexProgrammerDE AlexProgrammerDE linked a pull request Apr 9, 2020 that will close this issue
@AlexProgrammerDE AlexProgrammerDE removed a link to a pull request Apr 10, 2020
@tmigone
Copy link
Contributor

tmigone commented Apr 29, 2020

Quick update on this topic...
This issue is tracking progress on a solution to the stuttering problems.

@tmigone tmigone changed the title Sound cuts out or skips every 30 seconds or so, Pi 3 Sound stutters/cuts out or skips every 30 seconds or so Jul 17, 2020
@tmigone
Copy link
Contributor

tmigone commented Sep 3, 2020

In balenaSound 3.x this manifests as:

audio  E: [bluetooth] a2dp-codec-sbc.c: SBC decoding error (-3)
audio  E: [bluetooth] module-bluez5-device.c: Decoding error
audio  D: [bluetooth] module-bluez5-device.c: IO thread failed
audio  D: [pulseaudio] module-bluez5-device.c: Switching the profile to off due to IO thread failure.
audio  D: [pulseaudio] module-rescue-streams.c: No evacuation source found.

@jellyfish-bot
Copy link

jellyfish-bot commented Dec 2, 2020

[tmigone] This issue has attached support thread https://jel.ly.fish/3e72fcb6-9265-4c2e-b6fc-ca2895451e79

@AlexProgrammerDE AlexProgrammerDE changed the title Sound stutters/cuts out or skips every 30 seconds or so Sound stutters/cuts out or skips every 30 seconds (RTP and SCP error) Dec 31, 2020
@AlexProgrammerDE AlexProgrammerDE changed the title Sound stutters/cuts out or skips every 30 seconds (RTP and SCP error) Sound stutters/cuts out or skips every 30 seconds (RTP and SBC error) Dec 31, 2020
@theonlysinjin
Copy link

theonlysinjin commented Jan 12, 2021

After struggling all day to get this working on my Pi 3 B+....
The solution was to downgrade to 'v2.38.0+rev1'

I was receiving these issues and downgrade solved it...
audio E: [pulseaudio] backend-native.c: socket(SEQPACKET, SCO) Address family not supported by protocol
audio E: [bluetooth] a2dp-codec-sbc.c: SBC decoding error (-2)
audio E: [bluetooth] module-bluez5-device.c: Decoding error

@jellyfish-bot
Copy link

jellyfish-bot commented Jul 15, 2021

[klutchell] This issue has attached support thread https://jel.ly.fish/8d00d4e5-c146-472e-b2d7-9267b7180d58

@pjmartorell
Copy link

pjmartorell commented Jul 30, 2021

After struggling all day to get this working on my Pi 3 B+....
The solution was to downgrade to 'v2.38.0+rev1'

I was receiving these issues and downgrade solved it...
audio E: [pulseaudio] backend-native.c: socket(SEQPACKET, SCO) Address family not supported by protocol
audio E: [bluetooth] a2dp-codec-sbc.c: SBC decoding error (-2)
audio E: [bluetooth] module-bluez5-device.c: Decoding error

I downgraded and it works better but I still have similar errors like the ones you mentioned:

30.07.21 21:34:13 (+0200)  audio  E: [bluetooth] a2dp-codec-sbc.c: SBC decoding error (-3)
30.07.21 21:34:13 (+0200)  audio  E: [bluetooth] module-bluez5-device.c: Decoding error

When I disconnect and connect again to the device the issue is fixed temporarily but after a few seconds it fails again.

@jellyfish-bot
Copy link

jellyfish-bot commented Dec 23, 2021

[tmigone] This issue has attached support thread https://jel.ly.fish/0ecb5a6e-b6f9-45dc-b24b-45d6e4695ac7

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bluetooth Everything about the bluetooth container bug Something isn't working
Projects
None yet
Development

No branches or pull requests