Permalink
Browse files

gnuradio: Do not install -dev related packages with the gnuradio pack…

…age.

Install manuaully or use IMAGE_FEATURES. This lets you install the gnuradio
package in an image without exploding images size due to -dev packages
getting sucked in.

Signed-off-by: Philip Balister <philip@balister.org>
  • Loading branch information...
balister committed May 3, 2016
1 parent 3798f47 commit 380f9379f8946c33ae9e1dd558b3423367031bd5
Showing with 2 additions and 2 deletions.
  1. +2 −2 recipes-core/gnuradio/gnuradio_git.bb
@@ -61,12 +61,12 @@ GR_PACKAGES = "gnuradio-analog gnuradio-audio gnuradio-blocks \
gnuradio-trellis gnuradio-uhd gnuradio-vocoder \
gnuradio-volk gnuradio-volk-modtool gnuradio-wavelet \
gnuradio-examples \
gnuradio-staticdev gnuradio-dev gnuradio-doc gnuradio-zeromq \
gnuradio-doc gnuradio-zeromq \
"
GR_PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'qtgui', 'gnuradio-qtgui', '', d)}"
GR_PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'grc', 'gnuradio-grc', '', d)}"
PACKAGES = "gnuradio-dbg ${GR_PACKAGES} gnuradio"
PACKAGES = "gnuradio-dbg gnuradio-staticdev gnuradio-dev ${GR_PACKAGES} gnuradio"
FILES_${PN}-analog = "${PYTHON_SITEPACKAGES_DIR}/gnuradio/analog \
${datadir}/gnuradio/analog"

0 comments on commit 380f937

Please sign in to comment.