Permalink
Browse files

fixed an error that was stopping it from working in jruby. removed a …

…require that was causing an error
  • Loading branch information...
1 parent 7dd5cee commit 607c29bbdaff183e778f70294ef2bae4b11bef60 @ballantyne committed Dec 10, 2012
Showing with 2 additions and 3 deletions.
  1. +1 −2 lib/iciba.rb
  2. +1 −1 lib/iciba/version.rb
View
3 lib/iciba.rb
@@ -1,10 +1,9 @@
# coding: utf-8
-require "iciba/version"
require 'iciba/tools'
require 'iciba/fanyi'
class String
def contains_cjk?
- !!(self =~ /\p{Han}/)
+ !!(self.force_encoding("UTF-8") =~ /\p{Han}/)
end
end
View
2 lib/iciba/version.rb
@@ -1,3 +1,3 @@
module Iciba
- VERSION = "0.0.19"
+ VERSION = "0.0.20"
end

0 comments on commit 607c29b

Please sign in to comment.