New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Firefox 29 bekommt neues Sync mit Firefox Accounts #15

Closed
swiffer opened this Issue Jan 23, 2014 · 10 comments

Comments

Projects
None yet
9 participants
@swiffer
Copy link

swiffer commented Jan 23, 2014

@imcdona

This comment has been minimized.

Copy link

imcdona commented Jan 23, 2014

Any plans on making FSyncMS compatible with the new sync protocol?

@balu-

This comment has been minimized.

Copy link
Owner

balu- commented Jan 24, 2014

I would like to,
but it depends on wether there will be a protocol spec. (And of course if i'll find the time to do so )

@Trellmor

This comment has been minimized.

Copy link
Contributor

Trellmor commented Jan 24, 2014

There is a bug for the sync 1.5 protocol spec in the Firefox bugzilla.

Haven't read it completely yet, but it lists the changes from 1.1 to 1.5.

@balu-

This comment has been minimized.

Copy link
Owner

balu- commented Jan 24, 2014

i found some storage api 2.0 spec here https://docs.services.mozilla.com/storage/apis-2.0.html
but i'm not quite sure how up to date and how complete it is

@seraphyn

This comment has been minimized.

Copy link

seraphyn commented Mar 22, 2014

@Cobarith

This comment has been minimized.

Copy link

Cobarith commented May 1, 2014

I just stumbled over Firefox 29 bringing in the new sync service today - do you know by now whether or not you're going to update FSyncMS to work with it? Just to know if I should start looking around for alternatives.

@konfiot

This comment has been minimized.

Copy link

konfiot commented May 2, 2014

+1 that would be nice if newer Firefox versions were supported ! Retro compatibility would be an awesome extra, but I think it's not even possible

@konfiot

This comment has been minimized.

Copy link

konfiot commented May 2, 2014

Another page that seems to describe the protocol over there : https://github.com/mozilla/fxa-auth-server/wiki/onepw-protocol

@mahescho

This comment has been minimized.

Copy link

mahescho commented May 18, 2014

Even if FSyncMS could be modified to work with newer Firefox releases I see no way how to use a custom sync server in Firefox 29 when no (old) sync (with protocol version 1.1) is already configured in the profile

@fraenki

This comment has been minimized.

Copy link

fraenki commented Jun 12, 2014

FYI, there's a possibility that Mozilla will develop an Add-On to allow custom sync configs (and using your own sync server). See https://mail.mozilla.org/pipermail/sync-dev/2014-June/000894.html and https://bugzilla.mozilla.org/show_bug.cgi?id=989756 and https://bugzilla.mozilla.org/show_bug.cgi?id=1003877 for further details.

Still, FSyncMS would need to adopt the new API.

@swiffer swiffer closed this Sep 26, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment